summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/curl.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index d36519260e..021a3afcce 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -362,3 +362,31 @@ curl to obtain exactly that HTTP request.")
     (description "Coeurl is a simple library to do HTTP requests
 asynchronously via cURL in C++.")
     (license license:expat)))
+
+(define-public curlie
+  (package
+    (name "curlie")
+    (version "1.6.7")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/rs/curlie")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1kmp8kd5sahb7x01pkk80zs7dvsnziavjlk2igis499a3ddcjqmr"))))
+    (build-system go-build-system)
+    (arguments
+     `(#:import-path "github.com/rs/curlie"))
+    (inputs
+     (list curl go-golang-org-x-crypto go-golang-org-x-sys))
+    (home-page "https://curlie.io")
+    (synopsis "The power of curl, the ease of use of httpie")
+    (description "If you like the interface of HTTPie but miss the features of
+curl, curlie is what you are searching for.  Curlie is a frontend to
+@code{curl} that adds the ease of use of @code{httpie}, without compromising
+on features and performance.  All @code{curl} options are exposed with syntax
+sugar and output formatting inspired from @code{httpie}.")
+    (license license:expat)))