summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/django.scm10
-rw-r--r--gnu/packages/mail.scm2
-rw-r--r--gnu/packages/patchutils.scm2
3 files changed, 9 insertions, 5 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 2c9fdab6ad..38af7028b7 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -31,6 +31,7 @@
   #:use-module (guix download)
   #:use-module (guix git-download)
   #:use-module (guix build-system python)
+  #:use-module (guix deprecation)
   #:use-module (gnu packages)
   #:use-module (gnu packages base)
   #:use-module (gnu packages compression)
@@ -457,7 +458,7 @@ your code.")
            (lambda _
              (invoke "python" "runtests.py"))))))
     (native-inputs
-     (list python-django python-djangorestframework
+     (list python-django python-django-rest-framework
            python-django-crispy-forms python-mock))
     (home-page "https://django-filter.readthedocs.io/en/latest/")
     (synopsis "Reusable Django application to filter querysets dynamically")
@@ -1011,9 +1012,9 @@ Django projects, which allows association of a number of tags with any
 @code{Model} instance and makes retrieval of tags simple.")
     (license license:bsd-3)))
 
-(define-public python-djangorestframework
+(define-public python-django-rest-framework
   (package
-    (name "python-djangorestframework")
+    (name "python-django-rest-framework")
     (version "3.13.1")
     (source
      (origin
@@ -1047,6 +1048,9 @@ Django projects, which allows association of a number of tags with any
 provides features like a Web-browsable API and authentication policies.")
     (license license:bsd-2)))
 
+(define-public python-djangorestframework
+  (deprecated-package "python-djangorestframework" python-django-rest-framework))
+
 (define-public python-django-sekizai
   (package
     (name "python-django-sekizai")
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 5a1f5350eb..d6f279675b 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -3477,7 +3477,7 @@ which sends emails to HyperKitty, the official Mailman3 web archiver.")
            python-django-haystack
            python-django-mailman3
            python-django-q
-           python-djangorestframework
+           python-django-rest-framework
            python-flufl-lock
            python-mailmanclient
            python-mistune-next
diff --git a/gnu/packages/patchutils.scm b/gnu/packages/patchutils.scm
index 0dd7e0450f..9ac10dc8e4 100644
--- a/gnu/packages/patchutils.scm
+++ b/gnu/packages/patchutils.scm
@@ -460,7 +460,7 @@ if __name__ == \"__main__\":
            python-psycopg2
            python-mysqlclient
            python-django-filter
-           python-djangorestframework
+           python-django-rest-framework
            python-django-debug-toolbar))
     (synopsis "Web based patch tracking system")
     (description