summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk3
-rw-r--r--gnu/packages/algebra.scm7
-rw-r--r--gnu/packages/patches/fplll-std-fenv.patch18
3 files changed, 4 insertions, 24 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index a3760fbd47..ad6b5591a3 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1,6 +1,6 @@
 # GNU Guix --- Functional package management for GNU
 # Copyright © 2012-2021, 2021-2022 Ludovic Courtès <ludo@gnu.org>
-# Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020 Andreas Enge <andreas@enge.fr>
+# Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020, 2022 Andreas Enge <andreas@enge.fr>
 # Copyright © 2016 Mathieu Lirzin <mthl@gnu.org>
 # Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020, 2021 Mark H Weaver <mhw@netris.org>
 # Copyright © 2016 Chris Marusich <cmmarusich@gmail.com>
@@ -1073,7 +1073,6 @@ dist_patch_DATA =						\
   %D%/packages/patches/foomatic-filters-CVE-2015-8560.patch	\
   %D%/packages/patches/fp16-system-libraries.patch		\
   %D%/packages/patches/fpc-reproducibility.patch		\
-  %D%/packages/patches/fplll-std-fenv.patch     		\
   %D%/packages/patches/freedink-engine-fix-sdl-hints.patch	\
   %D%/packages/patches/freeglut-gcc-compat.patch		\
   %D%/packages/patches/freeimage-unbundle.patch		\
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 869a1373e5..5903b76664 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2022 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2013, 2015, 2017, 2018, 2021 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2016-2022 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2014, 2018 Mark H Weaver <mhw@netris.org>
@@ -154,7 +154,7 @@ line applications.")
 (define-public fplll
   (package
     (name "fplll")
-    (version "5.3.3")
+    (version "5.4.2")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -163,8 +163,7 @@ line applications.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "06nyfidagp8pc2kfcw88ldgb2b1xm0a8z31n0sln7j72ihlmd8zj"))
-              (patches (search-patches "fplll-std-fenv.patch"))))
+                "0044nyfnwzgyfrsikbcbh00f54dd61hwn3fb6711rrskkfnw977a"))))
     (build-system gnu-build-system)
     (native-inputs
      (list autoconf automake libtool pkg-config))
diff --git a/gnu/packages/patches/fplll-std-fenv.patch b/gnu/packages/patches/fplll-std-fenv.patch
deleted file mode 100644
index aa2438f0c9..0000000000
--- a/gnu/packages/patches/fplll-std-fenv.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-See https://github.com/fplll/fplll/issues/444
-
---- fplll-5.3.3-checkout.old/fplll/enum/enumerate_base.h	2020-09-23 13:55:27.833769823 +0200
-+++ fplll-5.3.3-checkout/fplll/enum/enumerate_base.h	2020-09-23 13:56:14.313771769 +0200
-@@ -127,10 +127,10 @@
-   int rounding_backup;
-   void save_rounding()
-   {
--    rounding_backup = std::fegetround();
--    std::fesetround(FE_TONEAREST);
-+    rounding_backup = fegetround();
-+    fesetround(FE_TONEAREST);
-   }
--  void restore_rounding() { std::fesetround(rounding_backup); }
-+  void restore_rounding() { fesetround(rounding_backup); }
- 
-   inline bool next_pos_up()
-   {