summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/gnupg.scm20
1 files changed, 10 insertions, 10 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index e81c89f719..bd8a7876bc 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -178,18 +178,18 @@ Daemon and possibly more in the future.")
      `(#:configure-flags
        (list (string-append "--with-libgpg-error-prefix="
                             (assoc-ref %build-inputs "libgpg-error-host"))
+             ;; libgcrypt is transitioning from gpg-error-config to
+             ;; gpgrt-config, and in the process the
+             ;; --with-libgpg-error-config prefix defined above is
+             ;; not respected.  See <https://dev.gnupg.org/T5365>.
+             ;; TODO: transition to pkg-config instead of these scripts.
+             (string-append "ac_cv_path_GPGRT_CONFIG="
+                            (assoc-ref %build-inputs
+                                       "libgpg-error-host")
+                            "/bin/gpgrt-config")
              ,@(if (%current-target-system)
                    ;; When cross-compiling, _gcry_mpih_lshift etc are undefined.
-                   `("--disable-asm"
-                     ;; libgcrypt is transitioning from gpg-error-config to
-                     ;; gpgrt-config, and in the process the
-                     ;; --with-libgpg-error-config prefix defined above is
-                     ;; not respected.  See <https://dev.gnupg.org/T5365>.
-                     ;; TODO: transition to pkg-config instead of these scripts.
-                     (string-append "ac_cv_path_GPGRT_CONFIG="
-                                    (assoc-ref %build-inputs
-                                               "libgpg-error-host")
-                                    "/bin/gpgrt-config"))
+                   `("--disable-asm")
                    '()))))
     (outputs '("out" "debug"))
     (home-page "https://gnupg.org/")