summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/julia.scm2
-rw-r--r--gnu/packages/machine-learning.scm2
-rw-r--r--gnu/packages/maths.scm20
-rw-r--r--gnu/packages/mpi.scm2
-rw-r--r--gnu/packages/python.scm4
-rw-r--r--gnu/packages/statistics.scm2
6 files changed, 16 insertions, 16 deletions
diff --git a/gnu/packages/julia.scm b/gnu/packages/julia.scm
index 9eb4badcef..4473109f4a 100644
--- a/gnu/packages/julia.scm
+++ b/gnu/packages/julia.scm
@@ -171,7 +171,7 @@
        ("double-conversion" ,double-conversion)
        ("fftw" ,fftw)
        ("fftwf" ,fftwf)
-       ("fortran" ,gfortran-4.8)
+       ("fortran" ,gfortran)
        ("pcre" ,pcre)
        ("utf8proc" ,utf8proc)
        ("git" ,git)
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index cfeb1daf63..30209f54af 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -133,7 +133,7 @@ classification.")
        ("libxml2" ,libxml2)
        ("zlib" ,zlib)))
     (native-inputs
-     `(("gfortran" ,gfortran-4.8)))
+     `(("gfortran" ,gfortran)))
     (home-page "http://www.imbs-luebeck.de/imbs/de/node/227/")
     (synopsis "Implementation of the Random Forests machine learning method")
     (description
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 421baf5e5b..4e0b1eee9c 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -265,7 +265,7 @@ be output in text, PostScript, PDF or HTML.")
     (home-page "https://github.com/opencollab/arpack-ng")
     (inputs
      `(("lapack" ,lapack)
-       ("fortran" ,gfortran-4.8)))
+       ("fortran" ,gfortran)))
     (synopsis "Fortran subroutines for solving eigenvalue problems")
     (description
      "ARPACK-NG is a collection of Fortran77 subroutines designed to solve
@@ -287,7 +287,7 @@ large scale eigenvalue problems.")
         "0lk3f97i9imqascnlf6wr5mjpyxqcdj73pgj97dj2mgvyg9z1n4s"))))
     (build-system cmake-build-system)
     (home-page "http://www.netlib.org/lapack/")
-    (inputs `(("fortran" ,gfortran-4.8)
+    (inputs `(("fortran" ,gfortran)
               ("python" ,python-2)))
     (arguments
      `(#:configure-flags '("-DBUILD_SHARED_LIBS:BOOL=YES")
@@ -400,7 +400,7 @@ extremely large and complex data collections.")
        ("glu" ,glu)
        ("zlib" ,zlib)))
     (native-inputs
-     `(("gfortran" ,gfortran-4.8)
+     `(("gfortran" ,gfortran)
        ("pkg-config" ,pkg-config)
        ("perl" ,perl)
        ;; The following inputs are not actually used in the build process.
@@ -445,7 +445,7 @@ script files.")
     (build-system cmake-build-system)
     (propagated-inputs
      `(("fltk" ,fltk)
-       ("gfortran" ,gfortran-4.8)
+       ("gfortran" ,gfortran)
        ("gmp" ,gmp)
        ("hdf5" ,hdf5)
        ("lapack" ,lapack)
@@ -487,7 +487,7 @@ ASCII text files using Gmsh's own scripting language.")
      `(("python" ,python-2)
        ("perl" ,perl)))
     (inputs
-     `(("gfortran" ,gfortran-4.8)
+     `(("gfortran" ,gfortran)
        ("lapack" ,lapack)
        ("superlu" ,superlu)
        ;; leaving out hdf5 and fftw, as petsc expects them to be built with mpi
@@ -615,7 +615,7 @@ scientific applications modeled by partial differential equations.")
      `(("tcsh" ,tcsh)))
     (inputs
      `(("lapack" ,lapack)
-       ("gfortran" ,gfortran-4.8)))
+       ("gfortran" ,gfortran)))
     (arguments
      `(#:parallel-build? #f
        #:tests? #f                      ;tests are run as part of `make all`
@@ -697,7 +697,7 @@ also provides threshold-based ILU factorization preconditioners.")
     (native-inputs
      `(("tcsh" ,tcsh)))
     (inputs
-     `(("gfortran" ,gfortran-4.8)))
+     `(("gfortran" ,gfortran)))
     (propagated-inputs
      `(("openmpi" ,openmpi)             ;headers include MPI heades
        ("lapack" ,lapack)               ;required to link with output library
@@ -1103,7 +1103,7 @@ constant parts of it.")
        ;; no configure script
        #:phases (alist-delete 'configure %standard-phases)))
     (inputs
-     `(("fortran" ,gfortran-4.8)))
+     `(("fortran" ,gfortran)))
     (native-inputs
      `(("cunit" ,cunit)
        ("perl" ,perl)))
@@ -1171,7 +1171,7 @@ environments.")
        ;; no configure script
        #:phases (alist-delete 'configure %standard-phases)))
     (inputs
-     `(("fortran" ,gfortran-4.8)))
+     `(("fortran" ,gfortran)))
     (home-page "https://github.com/JuliaLang/openspecfun")
     (synopsis "Collection of special mathematical functions")
     (description
@@ -1254,7 +1254,7 @@ packages.")
                 "0bqh4bdnjdyww4mcpg6kn0x7338mfqbdgysn97dzrwwb26di7ars"))))
     (build-system gnu-build-system)
     (home-page "http://math-atlas.sourceforge.net/")
-    (inputs `(("gfortran" ,gfortran-4.8)
+    (inputs `(("gfortran" ,gfortran)
               ("lapack-tar" ,(package-source lapack))))
     (outputs '("out" "doc"))
     ;; For the moment we drop support for MIPS at it fails to compile. See
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index a268239d5e..8e62da9701 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -97,7 +97,7 @@ bind processes, and much more.")
     (build-system gnu-build-system)
     (inputs
      `(("hwloc" ,hwloc)
-       ("gfortran" ,gfortran-4.8)
+       ("gfortran" ,gfortran)
        ("valgrind" ,valgrind)))
     (native-inputs
      `(("pkg-config" ,pkg-config)))
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index d503c787b1..4f7b1aae08 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2275,7 +2275,7 @@ writing C extensions for Python as easy as Python itself.")
        ("openblas" ,openblas)
        ("lapack" ,lapack)))
     (native-inputs
-     `(("gfortran" ,gfortran-4.8)))
+     `(("gfortran" ,gfortran)))
     (arguments
      `(#:phases
        (alist-cons-before
@@ -2620,7 +2620,7 @@ toolkits.")
        ("lapack" ,lapack)
        ("openblas" ,openblas)))
     (native-inputs
-     `(("gfortran" ,gfortran-4.8)
+     `(("gfortran" ,gfortran)
        ("texlive" ,texlive)
        ("perl" ,perl)))
     (outputs '("out" "doc"))
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 8d5d4c3d0a..0b9e081c69 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -90,7 +90,7 @@
     (inputs
      `(("atlas" ,atlas) ; --with-blas
        ("cairo" ,cairo)
-       ("gfortran" ,gfortran-4.9)
+       ("gfortran" ,gfortran)
        ("icu4c" ,icu4c)
        ("icedtea6" ,icedtea6 "jdk")
        ("lapack" ,lapack)