summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/linux.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index be18788687..b65303ae6f 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3082,6 +3082,10 @@ in a digital read-out.")
        (modify-phases %standard-phases
          (replace 'configure
            (lambda* (#:key inputs #:allow-other-keys)
+             ;; Don't build with '-Werror', really.
+             (substitute* "tools/lib/bpf/Makefile"
+               (("-Werror") ""))
+
              (setenv "SHELL_PATH" (which "bash"))
              (chdir "tools/perf")
              #t)))