summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/aux-files/run-in-namespace.c10
-rw-r--r--tests/guix-pack-relocatable.sh6
2 files changed, 13 insertions, 3 deletions
diff --git a/gnu/packages/aux-files/run-in-namespace.c b/gnu/packages/aux-files/run-in-namespace.c
index 551f4db88a..160f7da1c8 100644
--- a/gnu/packages/aux-files/run-in-namespace.c
+++ b/gnu/packages/aux-files/run-in-namespace.c
@@ -1,5 +1,5 @@
 /* GNU Guix --- Functional package management for GNU
-   Copyright (C) 2018, 2019 Ludovic Courtès <ludo@gnu.org>
+   Copyright (C) 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
 
    This file is part of GNU Guix.
 
@@ -343,7 +343,13 @@ Please refer to the 'guix pack' documentation for more information.\n");
 	    chdir ("/");			  /* avoid EBUSY */
 	    rm_rf (new_root);
 	    free (new_root);
-	    exit (status);
+
+	    if (WIFEXITED (status))
+	      exit (WEXITSTATUS (status));
+	    else
+	      /* Abnormal termination cannot really be reproduced, so exit
+		 with 255.  */
+	      exit (255);
 	  }
 	}
     }
diff --git a/tests/guix-pack-relocatable.sh b/tests/guix-pack-relocatable.sh
index e93610eedc..a3fd45623c 100644
--- a/tests/guix-pack-relocatable.sh
+++ b/tests/guix-pack-relocatable.sh
@@ -1,5 +1,5 @@
 # GNU Guix --- Functional package management for GNU
-# Copyright © 2018, 2019 Ludovic Courtès <ludo@gnu.org>
+# Copyright © 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
 #
 # This file is part of GNU Guix.
 #
@@ -72,6 +72,10 @@ then
     # mounting an empty file system on top of it.  That way, we exercise the
     # wrapper code that creates the user namespace and bind-mounts the store.
     unshare -mrf sh -c 'mount -t tmpfs none "$STORE_PARENT"; echo "$STORE_PARENT"/*; "$test_directory/Bin/sed" --version > "$test_directory/output"'
+
+    # Check whether the exit code is preserved.
+    if unshare -mrf sh -c 'mount -t tmpfs none "$STORE_PARENT"; echo "$STORE_PARENT"/*; "$test_directory/Bin/sed" --does-not-exist';
+    then false; else true; fi
 else
     # Run the relocatable 'sed' in the current namespaces.  This is a weak
     # test because we're going to access store items from the host store.