summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am1
-rw-r--r--doc.am1
-rw-r--r--doc/guix.texi29
-rw-r--r--guix/scripts/edit.scm79
-rw-r--r--po/guix/POTFILES.in1
5 files changed, 110 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index c8d701b3ba..784848d364 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -113,6 +113,7 @@ MODULES =					\
   guix/scripts/import/hackage.scm		\
   guix/scripts/environment.scm			\
   guix/scripts/publish.scm			\
+  guix/scripts/edit.scm				\
   guix.scm					\
   $(GNU_SYSTEM_MODULES)
 
diff --git a/doc.am b/doc.am
index d4ca0fc4a5..1c52066aa0 100644
--- a/doc.am
+++ b/doc.am
@@ -90,6 +90,7 @@ SUBCOMMANDS :=					\
   archive					\
   build						\
   download					\
+  edit						\
   environment					\
   gc						\
   hash						\
diff --git a/doc/guix.texi b/doc/guix.texi
index 1c7f4e1232..a93003d625 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -124,6 +124,7 @@ Defining Packages
 Utilities
 
 * Invoking guix build::         Building packages from the command line.
+* Invoking guix edit::
 * Invoking guix download::      Downloading a file and printing its hash.
 * Invoking guix hash::          Computing the cryptographic hash of a file.
 * Invoking guix import::        Importing package definitions.
@@ -1931,7 +1932,10 @@ unavailable to the build process, possibly leading to a build failure.
 
 Once a package definition is in place, the
 package may actually be built using the @code{guix build} command-line
-tool (@pxref{Invoking guix build}).  @xref{Packaging Guidelines}, for
+tool (@pxref{Invoking guix build}).  You can easily jump back to the
+package definition using the @command{guix edit} command
+(@pxref{Invoking guix edit}).
+@xref{Packaging Guidelines}, for
 more information on how to test package definitions, and
 @ref{Invoking guix lint}, for information on how to check a definition
 for style conformance.
@@ -3261,6 +3265,7 @@ programming interface of Guix in a convenient way.
 
 @menu
 * Invoking guix build::         Building packages from the command line.
+* Invoking guix edit::          Editing package definitions.
 * Invoking guix download::      Downloading a file and printing its hash.
 * Invoking guix hash::          Computing the cryptographic hash of a file.
 * Invoking guix import::        Importing package definitions.
@@ -3548,6 +3553,28 @@ the parsed command-line options.
 @end defvr
 
 
+@node Invoking guix edit
+@section Invoking @command{guix edit}
+
+@cindex package definition, editing
+So many packages, so many source files!  The @command{guix edit} command
+facilitates the life of packagers by pointing their editor at the source
+file containing the definition of the specified packages.  For instance:
+
+@example
+guix edit gcc-4.8 vim
+@end example
+
+@noindent
+launches the program specified in the @code{EDITOR} environment variable
+to edit the recipe of GCC@tie{}4.8.4 and that of Vim.
+
+If you are using Emacs, note that the Emacs user interface provides
+similar functionality in the ``package info'' buffers created by
+@kbd{M-x guix-search-by-name} and similar commands (@pxref{Emacs
+Commands}).
+
+
 @node Invoking guix download
 @section Invoking @command{guix download}
 
diff --git a/guix/scripts/edit.scm b/guix/scripts/edit.scm
new file mode 100644
index 0000000000..fc453ac38d
--- /dev/null
+++ b/guix/scripts/edit.scm
@@ -0,0 +1,79 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (guix scripts edit)
+  #:use-module (guix ui)
+  #:use-module (guix utils)
+  #:use-module (guix packages)
+  #:use-module (gnu packages)
+  #:use-module (srfi srfi-1)
+  #:use-module (srfi srfi-37)
+  #:export (%editor
+            guix-edit))
+
+(define %options
+  (list (option '(#\h "help") #f #f
+                (lambda args
+                  (show-help)
+                  (exit 0)))
+        (option '(#\V "version") #f #f
+                (lambda args
+                  (show-version-and-exit "guix edit")))))
+
+(define (show-help)
+  (display (_ "Usage: guix edit PACKAGE...
+Start $EDITOR to edit the definitions of PACKAGE...\n"))
+  (newline)
+  (display (_ "
+  -h, --help             display this help and exit"))
+  (display (_ "
+  -V, --version          display version information and exit"))
+  (newline)
+  (show-bug-report-information))
+
+(define %editor
+  (make-parameter (or (getenv "EDITOR") "emacsclient")))
+
+(define (search-path* path file)
+  "Like 'search-path' but exit if FILE is not found."
+  (let ((absolute-file-name (search-path path file)))
+    (unless absolute-file-name
+      ;; Shouldn't happen unless somebody fiddled with the 'location' field.
+      (leave (_ "file '~a' not found in search path ~s~%")
+             file path))
+    absolute-file-name))
+
+
+(define (guix-edit . args)
+  (with-error-handling
+    (let* ((specs    (parse-command-line args %options '(())
+                                         #:argument-handler cons))
+           (packages (map specification->package specs)))
+      (for-each (lambda (package)
+                  (unless (package-location package)
+                    (leave (_ "source location of package '~a' is unknown~%")
+                           (package-full-name package))))
+                packages)
+      (apply execlp (%editor) (%editor)
+             (append-map (lambda (package)
+                           (let ((loc (package-location package)))
+                             (list (string-append "+"
+                                                  (number->string
+                                                   (location-line loc)))
+                                   (search-path* %load-path (location-file loc)))))
+                         packages)))))
diff --git a/po/guix/POTFILES.in b/po/guix/POTFILES.in
index 4f27f54d6c..300486b666 100644
--- a/po/guix/POTFILES.in
+++ b/po/guix/POTFILES.in
@@ -16,6 +16,7 @@ guix/scripts/authenticate.scm
 guix/scripts/system.scm
 guix/scripts/lint.scm
 guix/scripts/publish.scm
+guix/scripts/edit.scm
 guix/gnu-maintenance.scm
 guix/ui.scm
 guix/http-client.scm