summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/icu4c.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/icu4c.scm b/gnu/packages/icu4c.scm
index 8c54cc915a..7eb3874322 100644
--- a/gnu/packages/icu4c.scm
+++ b/gnu/packages/icu4c.scm
@@ -68,10 +68,12 @@
         (lambda* (#:key outputs #:allow-other-keys)
           (let* ((out (assoc-ref outputs "out"))
                  (lib (string-append out "/lib")))
-            ;; Add LIB to the RUNPATH of all the libraries.
+            ;; Add LIB to the RUNPATH of all the binaries.
             (with-directory-excursion out
               (for-each (cut augment-rpath <> lib)
-                        (find-files "lib" ".*")))))
+                        (append
+                         (find-files "bin" ".*") 
+                         (find-files "sbin" ".*"))))))
         %standard-phases)))))
    (synopsis "ICU, International Components for Unicode")
    (description