summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/android.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/android.scm b/gnu/packages/android.scm
index 2da0a24f5c..2e5f1d5933 100644
--- a/gnu/packages/android.scm
+++ b/gnu/packages/android.scm
@@ -151,11 +151,16 @@ use their packages mostly unmodified in our Android NDK build system.")
     (build-system android-ndk-build-system)
     (arguments
      `(#:tests? #f ; TODO.
-       #:make-flags '("CC=gcc")
+       #:make-flags '("LDLIBS=-lpthread")
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'enter-source
-           (lambda _ (chdir "liblog") #t)))))
+           (lambda _ (chdir "liblog") #t))
+         (add-after 'install 'ldconfig
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out")))
+               (symlink "liblog.so.0" (string-append out "/lib/liblog.so"))
+               #t))))))
     (home-page "https://developer.android.com/")
     (synopsis "Logging library from the Android platform.")
     (description "@code{liblog} represents an interface to the volatile Android