summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/avahi.scm27
-rw-r--r--gnu/services/avahi.scm6
2 files changed, 30 insertions, 3 deletions
diff --git a/gnu/packages/avahi.scm b/gnu/packages/avahi.scm
index f4d17c5c15..001afa8d48 100644
--- a/gnu/packages/avahi.scm
+++ b/gnu/packages/avahi.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014, 2015, 2017 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
@@ -100,3 +100,28 @@ DNS-SD (for \"DNS-Based Service Discovery\") protocols.")
 most often used in home and other small networks without a local name server,
 to resolve host names in the @samp{.local} top-level domain.")
     (license lgpl2.1+)))
+
+(define-public nss-mdns-0.10
+  ;; Kept here to work around in bug in 0.11: <https://bugs.gnu.org/30396> and
+  ;; <https://github.com/lathiat/nss-mdns/issues/26>.
+  (package
+    (inherit nss-mdns)
+    (version "0.10")
+    (source (origin
+              (method url-fetch)
+              (uri (list
+                    (string-append
+                     "mirror://debian/pool/main/n/nss-mdns/nss-mdns_"
+                     version ".orig.tar.gz")
+                    "http://pkgs.fedoraproject.org/repo/pkgs/nss-mdns/nss-mdns-0.10.tar.gz/03938f17646efbb50aa70ba5f99f51d7/nss-mdns-0.10.tar.gz"
+
+                    ;; This used to be the canonical URL but it vanished.
+                    ;; See <http://bugs.gnu.org/18704>.
+                    ;; (string-append
+                    ;;  "http://0pointer.de/lennart/projects/nss-mdns/nss-mdns-"
+                    ;;  version ".tar.gz")
+                    ))
+              (sha256
+               (base32
+                "0vgs6j0qsl0mwzh5a0m0bykr7x6bx79vnbyn0r3q289rghp3qs0y"))
+              (file-name (string-append "nss-mdns-" version ".tar.gz"))))))
diff --git a/gnu/services/avahi.scm b/gnu/services/avahi.scm
index d69c89f751..b4f89c4abf 100644
--- a/gnu/services/avahi.scm
+++ b/gnu/services/avahi.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014, 2015, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -131,8 +131,10 @@ service switch (NSS) with support for @code{.local} host name resolution.")
                                             (const %avahi-accounts))
                          (service-extension activation-service-type
                                             (const %avahi-activation))
+
+                         ;; Use 0.10 due to <https://bugs.gnu.org/30396>.
                          (service-extension nscd-service-type
-                                            (const (list nss-mdns)))
+                                            (const (list nss-mdns-0.10)))
 
                          ;; Provide 'avahi-browse', 'avahi-resolve', etc. in
                          ;; the system profile.