summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/xorg.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 6c17170eef..fbb6367d05 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -4377,7 +4377,10 @@ tracking.")
                                     ; the compiled keyboard maps go?
              (string-append "--with-xkb-bin-directory="
                             (assoc-ref %build-inputs "xkbcomp")
-                            "/bin"))
+                            "/bin")
+
+             ;; For the log file, etc.
+             "--localstatedir=/var")
        #:phases
         (alist-replace
          'configure
@@ -4385,6 +4388,12 @@ tracking.")
            (let ((configure (assoc-ref %standard-phases 'configure)))
              (substitute* (find-files "." "\\.c$")
                (("/bin/sh") (which "sh")))
+
+             ;; Don't try to 'mkdir /var'.
+             (substitute* "hw/xfree86/Makefile.in"
+               (("mkdir(.*)logdir.*")
+                "true\n"))
+
              (apply configure args)))
          %standard-phases)))
     (home-page "http://www.x.org/wiki/")