summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/package-management.scm20
1 files changed, 19 insertions, 1 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 1cc2d3f6a0..560684e458 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -620,7 +620,25 @@ transactions from C or Python.")
                 ("xxd" ,xxd)))
       ;; Below are modules used for tests.
       (native-inputs `(("python-pytest" ,python-pytest)
-                       ("python-chardet" ,python-chardet)))
+                       ("python-chardet" ,python-chardet)
+                       ;; test suite skips tests when tool is missing
+                       ("bdb" ,bdb)
+                       ("binutils" ,binutils)
+                       ("bzip2" ,bzip2)
+                       ("colord" ,colord)
+                       ("cpio" ,cpio)
+                       ("e2fsprogs" ,e2fsprogs)
+                       ("gettext" ,gettext-minimal)
+                       ("gnumeric" ,gnumeric)
+                       ("gnupg" ,gnupg)
+                       ("libarchive" ,libarchive)
+                       ("lz4" ,lz4)
+                       ("openssh" ,openssh)
+                       ("rpm" ,rpm)
+                       ("sqlite" ,sqlite)
+                       ("squashfs-tools" ,squashfs-tools)
+                       ("xxd" ,xxd)
+                       ("xz" ,xz)))
       (home-page "https://diffoscope.org/")
       (synopsis "Compare files, archives, and directories in depth")
       (description