summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/bioinformatics.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index b273d2c540..28d138855d 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3529,6 +3529,12 @@ generated using the PacBio Iso-Seq protocol.")
             (lambda _
               (chdir "src")
               #t))
+         (add-after 'unpack 'remove-m64-flag
+           ;; Prank will build with the correct 'bit-ness' without this flag
+           ;; and this allows building on 32-bit machines.
+           (lambda _ (substitute* "src/Makefile"
+                                  (("-m64") ""))
+             #t))
          (delete 'configure)
          (replace 'install
            (lambda* (#:key outputs #:allow-other-keys)