summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/jami.scm32
1 files changed, 23 insertions, 9 deletions
diff --git a/gnu/packages/jami.scm b/gnu/packages/jami.scm
index 28c87a446e..ae4fb653bd 100644
--- a/gnu/packages/jami.scm
+++ b/gnu/packages/jami.scm
@@ -374,16 +374,21 @@
           '())))
 
 (define-public ffmpeg-jami
-  (package/inherit ffmpeg
+  (package
+    (inherit ffmpeg-5)
     (name "ffmpeg-jami")
+    ;; XXX: Use a slightly older version, otherwise the
+    ;; 'libopusdec-enable-FEC' patch doesn't apply.
+    (version "5.0.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://ffmpeg.org/releases/ffmpeg-"
+                                  version ".tar.xz"))
+              (sha256
+               (base32
+                "0yq0jcdc4qm5znrzylj3dsicrkk2n3n8bv28vr0a506fb7iglbpg"))))
     (arguments
-     (substitute-keyword-arguments (package-arguments ffmpeg)
-       ((#:tests? _ #f)
-        ;; The "rtp_ext_abs_send_time" patch causes the 'lavf-mov_rtphint'
-        ;; test to fail (see:
-        ;; https://git.jami.net/savoirfairelinux/jami-daemon/-/issues/685).
-        ;; TODO: Try to disable just this test.
-        #f)
+     (substitute-keyword-arguments (package-arguments ffmpeg-5)
        ((#:configure-flags '())
         (ffmpeg-compose-configure-flags))
        ((#:phases phases)
@@ -399,7 +404,16 @@
                              "rtp_ext_abs_send_time"
                              "libopusdec-enable-FEC"
                              "libopusenc-reload-packet-loss-at-encode"
-                             "screen-sharing-x11-fix"))))))))))
+                             "screen-sharing-x11-fix"))))
+            (add-after 'apply-patches 'disable-problematic-tests
+              (lambda _
+                ;; The "rtp_ext_abs_send_time" patch causes the 'lavf-mov_rtphint'
+                ;; test to fail (see:
+                ;; https://git.jami.net/savoirfairelinux/jami-daemon/-/issues/685).
+                (substitute* "tests/fate/lavf-container.mak"
+                  (("mov mov_rtphint ismv")
+                   "mov ismv")
+                  (("fate-lavf-mov_rtphint:.*") ""))))))))))
 
 (define-public libjami
   (package