summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/gps.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/gps.scm b/gnu/packages/gps.scm
index bc0f3ed115..0a9038b7a4 100644
--- a/gnu/packages/gps.scm
+++ b/gnu/packages/gps.scm
@@ -50,7 +50,10 @@
     (arguments
      `(#:configure-flags
        '("--with-zlib=system"
-         "CXXFLAGS=-std=gnu++11")
+         ;; XXX Use -fPIC to work around build problems with Qt, GCC 5, and
+         ;; recent binutils:
+         ;; https://codereview.qt-project.org/#/c/111787/
+         "CXXFLAGS=-std=gnu++11 -fPIC")
        #:phases
        (modify-phases %standard-phases
         (add-before 'configure 'pre-configure