summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/package-management.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index c6273efbd0..367caf4d29 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -262,6 +262,17 @@ $(prefix)/etc/openrc\n")))
                               (substitute* "tests/gexp.scm"
                                 (("2\\.0") "3.0")))))
                         '())
+                    ,@(if (target-x86-32?)
+                          `((add-after 'unpack 'disable-tests
+                              (lambda _
+                                (substitute* "Makefile.am"
+                                  (("tests/grafts.scm") "")
+                                  (("tests/offload.scm") "")
+                                  (("tests/packages.scm") "")
+                                  (("tests/guix-build.sh") "")
+                                  (("tests/guix-package.sh") "")
+                                  (("tests/guix-system.sh") "")))))
+                        '())
                     (add-before 'build 'use-host-compressors
                       (lambda* (#:key inputs target #:allow-other-keys)
                         (when target