summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ruby.scm31
1 files changed, 20 insertions, 11 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 68db28eb17..137879bbc4 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5424,17 +5424,26 @@ facilities supporting TDD, BDD, mocking, and benchmarking.")
                (base32
                 "03p6iban9gcpcflzp4z901s1hgj9369p6515h967ny6hlqhcf2iy"))))
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'remove-unsupported-method
-           (lambda _
-             (substitute* "Rakefile"
-               (("self\\.rubyforge_name = .*") ""))))
-         (add-after 'build 'exclude-failing-tests
-           (lambda _
-             ;; Some tests are failing on Ruby 2.4 due to the deprecation of
-             ;; Fixnum.
-             (delete-file "test/minitest/test_minitest_spec.rb"))))))))
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'remove-unsupported-method
+            (lambda _
+              (substitute* "Rakefile"
+                (("self\\.rubyforge_name = .*") ""))))
+          (add-after 'build 'patch-tests
+            (lambda _
+              ;; test_no_method_error_on_unexpected_methods
+              ;; This test fails due to some extra information in the message
+              (substitute* "test/minitest/test_minitest_mock.rb"
+                (("assert_equal expected, e.message")
+                 "assert_equal expected, e.message.lines.first.strip"))
+              ;; Some tests are failing on Ruby 2.4 due to the deprecation of
+              ;; Fixnum.
+              (delete-file "test/minitest/test_minitest_spec.rb"))))))
+    (native-inputs
+     (list ruby-minitest
+           ruby-hoe))))
 
 (define-public ruby-minitest-around
   (package