summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/mail.scm21
1 files changed, 10 insertions, 11 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index bfca298808..b739439083 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -2317,19 +2317,18 @@ format and headers.")
     (version "1.0.6")
     (source
      (origin
-       (method url-fetch)
-       (uri (list (string-append "https://pkgs.fedoraproject.org/repo/pkgs/"
-                                 "libesmtp/libesmtp-" version ".tar.bz2/"
-                                 "bf3915e627fd8f35524a8fdfeed979c8/libesmtp-"
-                                 version ".tar.bz2")
-                  ;; XXX This site is offline, so we fetch Fedora's cached copy
-                  ;; of the source tarball.
-                  (string-append "http://www.stafford.uklinux.net/libesmtp/libesmtp-"
-                                 version ".tar.bz2")))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/libesmtp/libESMTP")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
        (sha256
-        (base32
-         "02zbniyz7qys1jmx3ghx21kxmns1wc3hmv80gp7ag7yra9f1m9nh"))))
+        (base32 "0pylvjpdf92i0j9bl43sg37k1ksbzk1k7cgdk91kkcc0krh0r09g"))))
     (build-system gnu-build-system)
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("libtool" ,libtool)))
     (propagated-inputs
      `(("openssl" ,openssl)))
     (home-page "http://www.stafford.uklinux.net/libesmtp/")