summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/qt.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 67e8f895e9..297ddb169c 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1582,7 +1582,7 @@ module provides support functions to the automatically generated code.")
 (define-public python-pyqt
   (package
     (name "python-pyqt")
-    (version "5.9")
+    (version "5.10.1")
     (source
       (origin
         (method url-fetch)
@@ -1592,7 +1592,7 @@ module provides support functions to the automatically generated code.")
                          version ".tar.gz"))
         (sha256
          (base32
-          "15hh4z5vd45dcswjla58q6rrfr6ic7jfz2n7c8lwfb10rycpj3mb"))
+          "1vz9c4v0k8azk2b08swwybrshzw32x8djjpq13mf9v15x1qyjclr"))
        (patches (search-patches "pyqt-configure.patch"))))
     (build-system gnu-build-system)
     (native-inputs
@@ -1611,7 +1611,7 @@ module provides support functions to the automatically generated code.")
        ("qtsvg" ,qtsvg)
        ("qttools" ,qttools)
        ("qtwebchannel" ,qtwebchannel)
-       ("qtwebkit" ,qtwebkit)
+       ;("qtwebkit" ,qtwebkit)
        ("qtwebsockets" ,qtwebsockets)
        ("qtx11extras" ,qtx11extras)
        ("qtxmlpatterns" ,qtxmlpatterns)))
@@ -1620,6 +1620,12 @@ module provides support functions to the automatically generated code.")
                   ,@%gnu-build-system-modules)
        #:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'fix-build-with-qt-5.11
+           ;; See: https://bugs.gentoo.org/654742
+           (lambda _
+             (substitute* "sip/QtTest/qtestmouse.sip"
+               (("void waitForEvents\\(\\) /ReleaseGIL/;") ""))
+             #t))
          (replace 'configure
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))