summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/gcc.scm12
1 files changed, 5 insertions, 7 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index c5d21b50d9..75ee094531 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -295,15 +295,13 @@ where the OS part is overloaded to denote a specific ABI---into GCC
                     (substitute* "gcc/config/aarch64/t-aarch64-linux"
                       (("lib64") "lib")))
 
-                  ;; TODO: Make this unconditional in core-updates.
                   ;; The STARTFILE_PREFIX_SPEC prevents gcc from finding the
                   ;; gcc:lib output, which causes ld to not find -lgcc_s.
-                  ,@(if (target-riscv64?)
-                     `((when (file-exists? "gcc/config/riscv")
-                         (substitute* "gcc/config/riscv/linux.h"
-                           (("define STARTFILE_PREFIX_SPEC")
-                           "define __STARTFILE_PREFIX_SPEC"))))
-                     '())
+                  (when (file-exists? "gcc/config/riscv")
+                    (substitute* '("gcc/config/riscv/linux.h"
+                                   "gcc/config/riscv/riscv.h")  ; GCC < 10
+                      (("define STARTFILE_PREFIX_SPEC")
+                      "define __STARTFILE_PREFIX_SPEC")))
 
                   (when (file-exists? "libbacktrace")
                     ;; GCC 4.8+ comes with libbacktrace.  By default it builds