summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ots.scm23
1 files changed, 12 insertions, 11 deletions
diff --git a/gnu/packages/ots.scm b/gnu/packages/ots.scm
index d02a92768b..73dd5e4832 100644
--- a/gnu/packages/ots.scm
+++ b/gnu/packages/ots.scm
@@ -53,17 +53,18 @@
      ;; before libots-1.la has been built.
      '(#:parallel-build? #f
 
-       #:phases (alist-cons-after
-                 'configure 'set-shared-lib-extension
-                 (lambda _
-                   ;; For some reason, the 'libtool' script (from Libtool
-                   ;; 1.5.2, Debian variant) sets 'shrext_cmds' instead of
-                   ;; 'shrext' for the shared library file name extension.
-                   ;; This leads to the creation of 'libots-1' instead of
-                   ;; 'libots-1.so'.  Fix that.
-                   (substitute* "libtool"
-                     (("shrext_cmds") "shrext")))
-                 %standard-phases)))
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'configure 'set-shared-lib-extension
+           (lambda _
+             ;; For some reason, the 'libtool' script (from Libtool
+             ;; 1.5.2, Debian variant) sets 'shrext_cmds' instead of
+             ;; 'shrext' for the shared library file name extension.
+             ;; This leads to the creation of 'libots-1' instead of
+             ;; 'libots-1.so'.  Fix that.
+             (substitute* "libtool"
+               (("shrext_cmds") "shrext"))
+             #t)))))
     (inputs
       `(("glib" ,glib)
         ("popt" ,popt)