summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 39d0751f6a..d69c722de3 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -826,7 +826,13 @@ etc.).  The package is structured to make adding new modules easy.")
     (license public-domain)))
 
 (define-public python2-pycrypto
-  (package-with-python2 python-pycrypto))
+  (let ((pycrypto (package-with-python2 python-pycrypto)))
+    (package (inherit pycrypto)
+      (inputs
+       `(("python" ,python-2)
+         ,@(alist-delete
+            "python"
+            (package-inputs pycrypto)))))))
 
 (define-public python-keyring
   (package