summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/guile.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 6070fee000..96fc84a960 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -1707,6 +1707,11 @@ is not available for Guile 2.0.")
        '(#:phases (modify-phases %standard-phases
                     (add-after 'unpack 'bootstrap
                       (lambda _
+                        ;; Install .go files to "site-ccache", not "ccache".
+                        (substitute* "Makefile.am"
+                          (("/ccache")
+                           "/site-ccache"))
+
                         (zero? (system* "autoreconf" "-vfi")))))))
       (native-inputs
        `(("autoconf" ,autoconf)