summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk3
-rw-r--r--gnu/packages/admin.scm1
-rw-r--r--gnu/packages/patches/tree-disable-stddata.patch16
3 files changed, 1 insertions, 19 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 3335d368df..8163176950 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1862,9 +1862,8 @@ dist_patch_DATA =						\
   gnu/packages/patches/tootle-glib-object-naming.patch		\
   gnu/packages/patches/tootle-reason-phrase.patch		\
   %D%/packages/patches/tor-sandbox-i686.patch			\
-  %D%/packages/patches/transcode-ffmpeg.patch			\
+  %D%/packages/patches/transcode-ffmpeg.patch	\
   %D%/packages/patches/transmission-honor-localedir.patch	\
-  %D%/packages/patches/tree-disable-stddata.patch		\
   %D%/packages/patches/tremc-fix-decodestring.patch		\
   %D%/packages/patches/trytond-add-egg-modules-to-path.patch	\
   %D%/packages/patches/trytond-add-guix_trytond_path.patch	\
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 8a7d1b0615..c2e656db1a 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -2401,7 +2401,6 @@ recover lost partitions and/or make non-booting disks bootable again.")
               (uri (string-append
                     "http://mama.indstate.edu/users/ice/tree/src/tree-"
                     version ".tgz"))
-              (patches (search-patches "tree-disable-stddata.patch"))
               (sha256
                (base32 "0f92vx6gpz7v29wi9clklzah57v7lgx5kv0m1w4b9xjc35d9qcz3"))))
     (build-system gnu-build-system)
diff --git a/gnu/packages/patches/tree-disable-stddata.patch b/gnu/packages/patches/tree-disable-stddata.patch
deleted file mode 100644
index 52ca6e25f4..0000000000
--- a/gnu/packages/patches/tree-disable-stddata.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Tree 2.0.0 and later will write its output in JSON format on fd3 if
-present, instead of the requested output on fd1, which breaks e.g.
-'password-store' tests.  Disable for now; upstream has been notified.
-
-diff --git a/tree.c b/tree.c
---- a/tree.c
-+++ b/tree.c
-@@ -133,7 +133,7 @@ int main(int argc, char **argv)
-   mb_cur_max = 1;
- #endif
- 
--#ifdef __linux__
-+#if 0
-   // Output JSON automatically to "stddata" if present:
-   if (fcntl(STDDATA_FILENO, F_GETFD) >= 0) {
-     Jflag = noindent = TRUE;