summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am1
-rw-r--r--distro/packages/emacs.scm93
2 files changed, 94 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index dd08050641..7c36eff2fb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -61,6 +61,7 @@ MODULES =					\
   distro/packages/dejagnu.scm			\
   distro/packages/ddrescue.scm			\
   distro/packages/ed.scm			\
+  distro/packages/emacs.scm			\
   distro/packages/flex.scm			\
   distro/packages/gawk.scm			\
   distro/packages/gdb.scm			\
diff --git a/distro/packages/emacs.scm b/distro/packages/emacs.scm
new file mode 100644
index 0000000000..5a3d3f3910
--- /dev/null
+++ b/distro/packages/emacs.scm
@@ -0,0 +1,93 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (distro packages emacs)
+  #:use-module (guix licenses)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix build-system gnu)
+  #:use-module (distro)
+  #:use-module (distro packages ncurses)
+  #:use-module (distro packages texinfo)
+  #:use-module (distro packages gnutls)
+  #:use-module (distro packages pkg-config))
+
+(define-public emacs
+  (package
+    (name "emacs")
+    (version "24.2")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append "mirror://gnu/emacs/emacs-"
+                                 version ".tar.bz2"))
+             (sha256
+              (base32
+               "13wbjfjmz13qpjwssy44nw2230lllmkkgjsy0rqfm6am2cf87n3k"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:configure-flags
+       (list (string-append "--with-crt-dir=" (assoc-ref %build-inputs "libc")
+                            "/lib"))
+       #:patches (list (assoc-ref %build-inputs "patch/epaths"))
+       #:phases (alist-cons-before
+                 'configure 'fix-/bin/pwd
+                 (lambda _
+                   ;; Use `pwd', not `/bin/pwd'.
+                   (substitute* (find-files "." "^Makefile\\.in$")
+                     (("/bin/pwd")
+                      "pwd")))
+                 %standard-phases)))
+    (inputs
+     `(("pkg-config" ,pkg-config)
+       ("gnutls" ,gnutls)
+       ("texinfo" ,texinfo)
+       ("ncurses" ,ncurses)
+
+       ;; TODO: Add the optional dependencies.
+       ;; ("xlibs" ,xlibs)
+       ;; ("gtk+" ,gtk+)
+       ;; ("libXft" ,libXft)
+       ;; ("libtiff" ,libtiff)
+       ;; ("libungif" ,libungif)
+       ;; ("libjpeg" ,libjpeg)
+       ;; ("libpng" ,libpng)
+       ;; ("libXpm" ,libXpm)
+       ;; ("libxml2" ,libxml2)
+       ;; ("dbus-library" ,dbus-library)
+
+       ("patch/epaths" ,(search-patch "emacs-configure-sh.patch"))
+       ))
+    (home-page "http://www.gnu.org/software/emacs/")
+    (synopsis
+     "GNU Emacs 24, the extensible, customizable text editor")
+    (description
+     "GNU Emacs is an extensible, customizable text editor—and more.  At its
+core is an interpreter for Emacs Lisp, a dialect of the Lisp
+programming language with extensions to support text editing.
+
+The features of GNU Emacs include: content-sensitive editing modes,
+including syntax coloring, for a wide variety of file types including
+plain text, source code, and HTML; complete built-in documentation,
+including a tutorial for new users; full Unicode support for nearly all
+human languages and their scripts; highly customizable, using Emacs
+Lisp code or a graphical interface; a large number of extensions that
+add other functionality, including a project planner, mail and news
+reader, debugger interface, calendar, and more.  Many of these
+extensions are distributed with GNU Emacs; others are available
+separately.")
+    (license gpl3+)))