summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/linux.scm3
-rw-r--r--gnu/packages/patches/libaio-32bit-test.patch26
3 files changed, 29 insertions, 1 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index a4954f9b35..6a7e41c476 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1406,6 +1406,7 @@ dist_patch_DATA =						\
   %D%/packages/patches/liba52-link-with-libm.patch		\
   %D%/packages/patches/liba52-set-soname.patch			\
   %D%/packages/patches/liba52-use-mtune-not-mcpu.patch		\
+  %D%/packages/patches/libaio-32bit-test.patch                  \
   %D%/packages/patches/libbase-fix-includes.patch		\
   %D%/packages/patches/libbase-use-own-logging.patch		\
   %D%/packages/patches/libbonobo-activation-test-race.patch	\
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 9da2e62c07..e95e771bf2 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -5535,7 +5535,8 @@ Linux Device Mapper multipathing driver:
                                    name "-" version ".tar.gz")))
               (sha256
                (base32
-                "02r0g2vfv6kfljplm3ga93w4xw13q2wixbn9hwi7ahqdzp2x2i1c"))))
+                "02r0g2vfv6kfljplm3ga93w4xw13q2wixbn9hwi7ahqdzp2x2i1c"))
+              (patches (search-patches "libaio-32bit-test.patch"))))
     (build-system gnu-build-system)
     (arguments
      (list #:make-flags
diff --git a/gnu/packages/patches/libaio-32bit-test.patch b/gnu/packages/patches/libaio-32bit-test.patch
new file mode 100644
index 0000000000..0da8e25c69
--- /dev/null
+++ b/gnu/packages/patches/libaio-32bit-test.patch
@@ -0,0 +1,26 @@
+This fix comes from an upstream pull request, see
+https://pagure.io/libaio/pull-request/22#commit_list
+
+diff --git a/harness/cases/23.t b/harness/cases/23.t
+index cc5a8a1..9bbb05c 100644
+--- a/harness/cases/23.t
++++ b/harness/cases/23.t
+@@ -72,7 +72,7 @@ static void fail_errno(const char *format, ...)
+ static void *thrproc2(void *arg)
+ {
+ 	for (;;) {
+-		off_t offset = 0;
++		off64_t offset = 0;
+ 
+ 		pthread_barrier_wait(&barrier);
+ 		if (exiting)
+@@ -92,7 +92,7 @@ static void *thrproc3(void *arg)
+ {
+ 	for (;;) {
+ 		char c;
+-		off_t offset = 0;
++		off64_t offset = 0;
+ 
+ 		pthread_barrier_wait(&barrier);
+ 		if (exiting)
+