summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ruby.scm25
1 files changed, 1 insertions, 24 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 3480adba65..bb7d865f21 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -162,11 +162,6 @@ a focus on simplicity and productivity.")
                (base32
                 "0i8dimf8kxcjgqj9x65bbi3l6hc9p9gbfbb1vmrz42764a4jjbz9"))) )
     (build-system ruby-build-system)
-    (arguments
-     '(#:phases (alist-replace
-                 'build
-                 (lambda _ (zero? (system* "rake" "gem")))
-                 %standard-phases)))
     (synopsis "Ruby project management helper")
     (description
      "Hoe is a rake/rubygems helper for project Rakefiles.  It helps manage,
@@ -198,9 +193,7 @@ announcement.")
                     (lambda _
                       ;; Remove cucumber test file because the
                       ;; dependencies are not available right now.
-                      (delete-file "tasks/cucumber.rake")))
-                  (replace 'build
-                    (lambda _ (zero? (system* "rake" "gem")))))))
+                      (delete-file "tasks/cucumber.rake"))))))
     (synopsis "Building and packaging helper for Ruby native extensions")
     (description "Rake-compiler proivides a framework for building and
 packaging native C and Java extensions in Ruby.")
@@ -517,10 +510,6 @@ interface for Ruby programs.")
                (base32
                 "1q18vji31w8gfr6ajziqkqs8n5lzkw0bl00dm2a8s05zhavzw9j9"))))
     (build-system ruby-build-system)
-    (arguments
-     '(#:phases (modify-phases %standard-phases
-                  (replace 'build ; no gemspec
-                    (lambda _ (zero? (system* "rake" "gem")))))))
     (native-inputs
      `(("ruby-connection-pool" ,ruby-connection-pool)
        ("ruby-hoe" ,ruby-hoe)))
@@ -546,10 +535,6 @@ using Net::HTTP, supporting reconnection and retry according to RFC 2616.")
                (base32
                 "09xjiahk7q8hid1i39ahrmghaslpj9n36zna72i3ah7kf1bh2l01"))))
     (build-system ruby-build-system)
-    (arguments
-     '(#:phases (modify-phases %standard-phases
-                  (replace 'build ; no gemspec
-                    (lambda _ (zero? (system* "rake" "gem")))))))
     (native-inputs
      `(("ruby-hoe" ,ruby-hoe)))
     (synopsis "Small test suite library for Ruby")
@@ -572,10 +557,6 @@ facilities supporting TDD, BDD, mocking, and benchmarking.")
                (base32
                 "0rbmxz94lqg5vjz60p8v2bzq8adwvmx501amvk0l124sfwmw94ms"))))
     (build-system ruby-build-system)
-    (arguments
-     '(#:phases (modify-phases %standard-phases
-                  (replace 'build ; no gemspec
-                    (lambda _ (zero? (system* "rake" "gem")))))))
     (native-inputs
      `(("ruby-hoe" ,ruby-hoe)
        ("ruby-minitest" ,ruby-minitest)))
@@ -599,10 +580,6 @@ easier to re-run individual failing tests.")
                (base32
                 "19r9fm41i0mm1xncqls8frbj1i9nr3sq1cx2mh878r6kdl02d70h"))))
     (build-system ruby-build-system)
-    (arguments
-     '(#:phases (modify-phases %standard-phases
-                  (replace 'build ; no gemspec
-                    (lambda _ (zero? (system* "rake" "gem")))))))
     (native-inputs
      `(("ruby-hoe" ,ruby-hoe)))
     (inputs