summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/dns.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index cd809fa9b9..5e85aba5ec 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -782,6 +782,13 @@ served by AS112.  Stub and forward zones are supported.")
            (lambda _
              (substitute* "Makefile.in"
                ((" (etc|var)") ""))
+             #t))
+         (add-after 'configure 'omit-spurious-references
+           (lambda _
+             ;; The many Makefile.in grep this(!) to #define BUILD_OPTIONS.
+             (substitute* "config.log"
+               (("(=/gnu/store/)[^-]*" _ match)
+                (string-append match "...")))
              #t)))
        #:configure-flags
        (list "--sysconfdir=/etc"