summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/backup.scm15
1 files changed, 14 insertions, 1 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 9884f58fc3..74ee67c70c 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -485,8 +485,21 @@ detection, and lossless compression.")
        (modules '((guix build utils)))
        (snippet
         '(begin
+           ;; Delete files generated by Cython.  We used to have a regex
+           ;; that created the list of generated files but Borg has
+           ;; added new non-generated C files that cause the regex to
+           ;; generate the wrong list.
            (for-each delete-file
-                     (find-files "borg" "^(c|h|p).*\\.c$"))
+                     '("src/borg/algorithms/checksums.c"
+                       "src/borg/chunker.c"
+                       "src/borg/compress.c"
+                       "src/borg/crypto/low_level.c"
+                       "src/borg/hashindex.c"
+                       "src/borg/item.c"
+                       "src/borg/platform/darwin.c"
+                       "src/borg/platform/freebsd.c"
+                       "src/borg/platform/linux.c"
+                       "src/borg/platform/posix.c"))
            ;; Remove bundled shared libraries.
            (with-directory-excursion "src/borg/algorithms"
              (for-each delete-file-recursively