summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/audio.scm9
-rw-r--r--gnu/packages/emacs.scm4
-rw-r--r--gnu/packages/fontutils.scm4
-rw-r--r--gnu/packages/libevent.scm6
-rw-r--r--gnu/packages/linux.scm4
-rw-r--r--gnu/packages/mail.scm13
-rw-r--r--gnu/packages/package-management.scm6
-rw-r--r--gnu/packages/rdf.scm6
-rw-r--r--gnu/packages/tor.scm6
-rw-r--r--gnu/packages/web.scm17
10 files changed, 31 insertions, 44 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 52feea3701..bc21c9f1f9 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -804,13 +804,10 @@ stretching and pitch scaling of audio.  This package contains the library.")
        ("file" ,file)))
     (arguments
      '(#:phases
-       (alist-cons-before
-        'configure 'bootstrap
+       (alist-cons-after
+        'unpack 'bootstrap
         (lambda _
-          (unless (zero? (system* "sh" "bootstrap"))
-            (error "bootstrap failed"))
-          (substitute* '("configure")
-            (("/usr/bin/file") "file")))
+          (zero? (system* "sh" "bootstrap")))
         %standard-phases)))
     (home-page "http://www.surina.net/soundtouch/")
     (synopsis
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index f4d7ac9748..b2a151a68e 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -309,8 +309,8 @@ operations.")
                               out "/share/images/emacs-w3m")))
        #:tests? #f  ; no check target
        #:phases
-       (alist-cons-before
-        'configure 'pre-configure
+       (alist-cons-after
+        'unpack 'autoconf
         (lambda _
           (zero? (system* "autoconf")))
         (alist-cons-before
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 14f42a9236..52e34e516f 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -278,8 +278,8 @@ smooth contours with constant curvature at the spline joins.")
                      ("automake" ,automake)
                      ("libtool" ,libtool)))
     (arguments
-     `(#:phases (alist-cons-before
-                 'configure 'bootstrap
+     `(#:phases (alist-cons-after
+                 'unpack 'bootstrap
                  (lambda _
                    (zero? (system* "autoreconf" "-vi")))
                  %standard-phases)))
diff --git a/gnu/packages/libevent.scm b/gnu/packages/libevent.scm
index 64892bf878..2afae3f302 100644
--- a/gnu/packages/libevent.scm
+++ b/gnu/packages/libevent.scm
@@ -73,12 +73,12 @@ loop.")
                 "1ys2wlypdbv59yywn91d5vl329z50mi7ivi3fj5rjm4mr9g3wnmr"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:phases (alist-cons-before
-                 'configure 'autogen
+     '(#:phases (alist-cons-after
+                 'unpack 'autogen
                  (lambda _
                    ;; Fashionable people don't run 'make dist' these days, so
                    ;; we need to do that ourselves.
-                   (zero? (system* "./autogen.sh")))
+                   (zero? (system* "sh" "autogen.sh")))
                  %standard-phases)
 
        ;; XXX: Some tests want /dev/tty, attempt to make connections, etc.
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 4fe6f887cf..b7eedc6be2 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1005,8 +1005,8 @@ Linux-based operating systems.")
     (native-inputs `(("autoconf" ,autoconf)
                      ("automake" ,automake)))
     (arguments
-     '(#:phases (alist-cons-before
-                 'configure 'bootstrap
+     '(#:phases (alist-cons-after
+                 'unpack 'bootstrap
                  (lambda _
                    (zero? (system* "autoreconf" "-vf")))
                  %standard-phases)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index dc33c8cbd3..17988cc4f9 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -1,6 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
 ;;; Copyright © 2014 Sou Bunnbu <iyzsong@gmail.com>
 ;;; Copyright © 2014 Julien Lepiller <julien@lepiller.eu>
@@ -432,14 +432,11 @@ useful features.")
      `(("curl" ,curl)
        ("expat" ,expat)))
     (arguments
-      '(#:phases (alist-cons-before
-                  'configure 'autogen
+      '(#:phases (alist-cons-after
+                  'unpack 'autogen
                   (lambda _
-                    (system* "./autogen.sh")) ;; Note: this fails because the
-                         ;; generated configure script uses /bin/sh. It is
-                         ;; replaced in the configure phase by the correct
-                         ;; value. TODO: replace the configure phase by the
-                         ;; autogen phase and have the SHELL variable be replaced
+                    (setenv "NOCONFIGURE" "true")
+                    (zero? (system* "sh" "autogen.sh")))
                   %standard-phases)
         #:configure-flags
         '("--disable-static" "--disable-db")))
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 97e96c712f..65b4e9b55b 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -156,15 +156,15 @@ the Nix package manager.")
       (arguments
        (substitute-keyword-arguments (package-arguments guix-0.8.1)
          ((#:phases phases)
-          `(alist-cons-before
-            'configure 'bootstrap
+          `(alist-cons-after
+            'unpack 'bootstrap
             (lambda _
               ;; Make sure 'msgmerge' can modify the PO files.
               (for-each (lambda (po)
                           (chmod po #o666))
                         (find-files "." "\\.po$"))
 
-              (zero? (system* "./bootstrap")))
+              (zero? (system* "sh" "bootstrap")))
             ,phases))))
       (native-inputs
        `(("autoconf" ,(autoconf-wrapper))
diff --git a/gnu/packages/rdf.scm b/gnu/packages/rdf.scm
index 5102ebe921..8edc2f46fc 100644
--- a/gnu/packages/rdf.scm
+++ b/gnu/packages/rdf.scm
@@ -140,9 +140,9 @@ Java Lucene text search engine API to C++.")
                    (substitute* "examples/Makefile.am"
                      (("instances_test remove_test") "instances_test")
                      (("\\$\\(TESTS\\) remove_test") "$(TESTS)")))
-                 (alist-cons-before
-                  'configure 'autoreconf
-                  (lambda* (#:key inputs #:allow-other-keys)
+                 (alist-cons-after
+                  'remove-out-of-tree-references 'autoreconf
+                  (lambda _
                     (zero? (system* "autoreconf" "-vfi")))
                   %standard-phases))))
     (inputs
diff --git a/gnu/packages/tor.scm b/gnu/packages/tor.scm
index db0415adbf..73becbba92 100644
--- a/gnu/packages/tor.scm
+++ b/gnu/packages/tor.scm
@@ -1,6 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -99,8 +99,8 @@ rejects UDP traffic from the application you're using.")
        #:configure-flags (list (string-append "--sysconfdir="
                                               (assoc-ref %outputs "out")
                                               "/etc/privoxy"))
-       #:phases (alist-cons-before
-                 'configure 'autoconf
+       #:phases (alist-cons-after
+                 'unpack 'autoconf
                  (lambda _
                    ;; Unfortunately, this is not a tarball produced by
                    ;; "make dist".
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 5296c43c53..f0f974661b 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -2,7 +2,7 @@
 ;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2013 Aljosha Papsch <misc@rpapsch.de>
 ;;; Copyright © 2014, 2015 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
 ;;;
@@ -258,18 +258,11 @@ for efficient socket-like bidirectional reliable communication channels.")
                      ("which"    ,which)
                      ("libtool"  ,libtool)))
     (arguments
-     `(#:phases (alist-cons-before
-                 'bootstrap 'fix-autogen-shebang
+     `(#:phases (alist-cons-after
+                 'unpack 'bootstrap
                  (lambda _
-                   (substitute* "autogen.sh"
-                     ;; Removing -e as it causes the whole script to fail when
-                     ;; `which gtkdocize` fails.
-                     (("# !/bin/sh -e") (string-append "#!" (which "sh")))))
-                 (alist-cons-before
-                  'patch-usr-bin-file 'bootstrap
-                  (lambda _
-                    (zero? (system* "./autogen.sh")))
-                  %standard-phases))))
+                   (zero? (system* "sh" "autogen.sh")))
+                 %standard-phases)))
     (home-page "https://github.com/rockdaboot/libpsl")
     (synopsis "C library for the Publix Suffix List")
     (description