summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/samba.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index ecfbdd1af0..128397f7d5 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -88,10 +88,10 @@
              (invoke "autoreconf" "-vfi")
              #t))
          (add-before 'configure 'set-root-sbin
-           (lambda _
+           (lambda* (#:key outputs #:allow-other-keys)
              ;; Don't try to install into "/sbin".
              (setenv "ROOTSBINDIR"
-                     (string-append (assoc-ref %outputs "out") "/sbin"))
+                     (string-append (assoc-ref outputs "out") "/sbin"))
              #t))
          (add-before 'install 'create-man8dir
            ;; Create a directory that isn't created since version 6.10.