summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--configure.ac9
-rw-r--r--gnu/local.mk49
2 files changed, 35 insertions, 23 deletions
diff --git a/configure.ac b/configure.ac
index 83a9b87d77..5d70de4beb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -137,9 +137,18 @@ fi
 
 dnl Guile-newt is used by the graphical installer.
 GUILE_MODULE_AVAILABLE([have_guile_newt], [(newt)])
+
+AC_ARG_ENABLE([installer],
+    AS_HELP_STRING([--enable-installer], [Build the graphical installer sources.]))
+
+AS_IF([test "x$enable_installer" = "xyes"], [
 if test "x$have_guile_newt" != "xyes"; then
   AC_MSG_ERROR([Guile-newt could not be found; please install it.])
 fi
+])
+
+AM_CONDITIONAL([ENABLE_INSTALLER],
+  [test "x$enable_installer" = "xyes"])
 
 dnl Make sure we have a full-fledged Guile.
 GUIX_ASSERT_GUILE_FEATURES([regex posix socket net-db threads])
diff --git a/gnu/local.mk b/gnu/local.mk
index 3e6d30d8e9..665721bec1 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -543,6 +543,29 @@ GNU_SYSTEM_MODULES =				\
   %D%/build/marionette.scm			\
   %D%/build/vm.scm				\
 						\
+  %D%/tests.scm					\
+  %D%/tests/audio.scm				\
+  %D%/tests/base.scm				\
+  %D%/tests/databases.scm			\
+  %D%/tests/desktop.scm				\
+  %D%/tests/dict.scm				\
+  %D%/tests/docker.scm				\
+  %D%/tests/monitoring.scm                      \
+  %D%/tests/nfs.scm				\
+  %D%/tests/install.scm				\
+  %D%/tests/mail.scm				\
+  %D%/tests/messaging.scm			\
+  %D%/tests/networking.scm			\
+  %D%/tests/rsync.scm				\
+  %D%/tests/security-token.scm			\
+  %D%/tests/ssh.scm				\
+  %D%/tests/version-control.scm			\
+  %D%/tests/virtualization.scm			\
+  %D%/tests/web.scm
+
+if ENABLE_INSTALLER
+
+GNU_SYSTEM_MODULES +=                           \
   %D%/installer.scm      			\
   %D%/installer/build-installer.scm		\
   %D%/installer/connman.scm			\
@@ -563,29 +586,9 @@ GNU_SYSTEM_MODULES =				\
   %D%/installer/newt/timezone.scm		\
   %D%/installer/newt/utils.scm			\
   %D%/installer/newt/welcome.scm		\
-  %D%/installer/newt/wifi.scm			\
-						\
-  %D%/tests.scm					\
-  %D%/tests/audio.scm				\
-  %D%/tests/base.scm				\
-  %D%/tests/databases.scm			\
-  %D%/tests/desktop.scm				\
-  %D%/tests/dict.scm				\
-  %D%/tests/docker.scm				\
-  %D%/tests/monitoring.scm                      \
-  %D%/tests/nfs.scm				\
-  %D%/tests/install.scm				\
-  %D%/tests/mail.scm				\
-  %D%/tests/messaging.scm			\
-  %D%/tests/networking.scm			\
-  %D%/tests/rsync.scm				\
-  %D%/tests/security-token.scm			\
-  %D%/tests/ssh.scm				\
-  %D%/tests/version-control.scm			\
-  %D%/tests/virtualization.scm			\
-  %D%/tests/web.scm				\
-						\
-  %D%/ci.scm
+  %D%/installer/newt/wifi.scm	
+
+endif ENABLE_INSTALLER
 
 # Modules that do not need to be compiled.
 MODULES_NOT_COMPILED +=				\