summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/algebra.scm12
1 files changed, 4 insertions, 8 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 318d653618..56a9a65366 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -151,12 +151,7 @@ line applications.")
 (define-public fplll
   (package
     (name "fplll")
-    ;; The most recent version 5.3.3 fails in the configure phase:
-    ;; ./configure: line 12956: syntax error near unexpected token `LIBQD,'
-    ;; ./configure: line 12956: `  PKG_CHECK_MODULES(LIBQD, qd, have_libqd="yes",'
-    ;; The error disappears when adding qd as an input; but this is
-    ;; supposed to be an optional input.
-    (version "5.3.2")
+    (version "5.3.3")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -165,12 +160,13 @@ line applications.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "00iyz218ywspizjiimrjdcqvdqmrsb2367zyy3vkmypnf9i9l680"))))
+                "06nyfidagp8pc2kfcw88ldgb2b1xm0a8z31n0sln7j72ihlmd8zj"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("autoconf" ,autoconf)
        ("automake" ,automake)
-       ("libtool" ,libtool)))
+       ("libtool" ,libtool)
+       ("pkg-config" ,pkg-config)))
     (inputs
      `(("gmp" ,gmp)
        ("mpfr" ,mpfr)))