summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/make-bootstrap.scm49
1 files changed, 24 insertions, 25 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index 60b6f1b42e..32542f6da7 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -623,31 +623,30 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
 ;; Two packages: first build static, bare minimum content.
 (define-public %mes-minimal
   ;; A minimal Mes without documentation.
-  (let ((triplet "i686-unknown-linux-gnu"))
-    (package
-      (inherit mes-0.19)
-      (name "mes-minimal")
-      (native-inputs
-       `(("guile" ,guile-2.2)))
-      (arguments
-       `(#:system "i686-linux"
-         #:strip-binaries? #f
-         #:configure-flags '("--mes")
-         #:phases
-         (modify-phases %standard-phases
-           (delete 'patch-shebangs)
-           (add-after 'install 'strip-install
-             (lambda _
-               (let* ((out (assoc-ref %outputs "out"))
-                      (share (string-append out "/share")))
-                 (delete-file-recursively (string-append out "/lib/guile"))
-                 (delete-file-recursively (string-append share "/guile"))
-                 (delete-file-recursively (string-append share "/mes/scaffold"))
-
-                 (for-each delete-file
-                           (find-files
-                            (string-append share "/mes/lib")
-                            "\\.(h|c)")))))))))))
+  (package
+    (inherit mes-0.19)
+    (name "mes-minimal")
+    (native-inputs
+     `(("guile" ,guile-2.2)))
+    (arguments
+     `(#:system "i686-linux"
+       #:strip-binaries? #f
+       #:configure-flags '("--mes")
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'patch-shebangs)
+         (add-after 'install 'strip-install
+           (lambda _
+             (let* ((out (assoc-ref %outputs "out"))
+                    (share (string-append out "/share")))
+               (delete-file-recursively (string-append out "/lib/guile"))
+               (delete-file-recursively (string-append share "/guile"))
+               (delete-file-recursively (string-append share "/mes/scaffold"))
+
+               (for-each delete-file
+                         (find-files
+                          (string-append share "/mes/lib")
+                          "\\.(h|c)"))))))))))
 
 ;; next remove store references.
 (define %mes-minimal-stripped