summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/check.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 82391ac5e1..2a0da625fd 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -925,6 +925,27 @@ result back.")
 (define-public python2-pytest-xdist
   (package-with-python2 python-pytest-xdist))
 
+(define-public python-pytest-timeout
+  (package
+    (name "python-pytest-timeout")
+    (version "1.3.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pytest-timeout" version))
+       (sha256
+        (base32
+         "1cczcjhw4xx5sjkhxlhc5c1bkr7x6fcyx12wrnvwfckshdvblc2a"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-pytest" ,python-pytest)))
+    (home-page "http://bitbucket.org/pytest-dev/pytest-timeout/")
+    (synopsis "Plugin for py.test to abort hanging tests")
+    (description
+     "This package provides a py.test plugin that aborts hanging tests after a
+timeout has been exceeded.")
+    (license license:expat)))
+
 (define-public python-scripttest
   (package
     (name "python-scripttest")