summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/patches/wicd-wpa2-ttls.patch38
-rw-r--r--gnu/packages/wicd.scm4
3 files changed, 42 insertions, 1 deletions
diff --git a/gnu-system.am b/gnu-system.am
index 1e730d96da..d45b3d1f0f 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -781,6 +781,7 @@ dist_patch_DATA =						\
   gnu/packages/patches/wicd-bitrate-none-fix.patch		\
   gnu/packages/patches/wicd-get-selected-profile-fix.patch	\
   gnu/packages/patches/wicd-urwid-1.3.patch			\
+  gnu/packages/patches/wicd-wpa2-ttls.patch			\
   gnu/packages/patches/wmctrl-64-fix.patch			\
   gnu/packages/patches/wpa-supplicant-CVE-2015-5310.patch	\
   gnu/packages/patches/wpa-supplicant-CVE-2015-5314.patch	\
diff --git a/gnu/packages/patches/wicd-wpa2-ttls.patch b/gnu/packages/patches/wicd-wpa2-ttls.patch
new file mode 100644
index 0000000000..9d80ee7ed2
--- /dev/null
+++ b/gnu/packages/patches/wicd-wpa2-ttls.patch
@@ -0,0 +1,38 @@
+Add a template for WPA2-TTLS, which is notably used by Eduroam.
+
+--- a/encryption/templates/active
++++ b/encryption/templates/active
+@@ -4,6 +4,7 @@ wpa-psk
+ wpa-psk-hex
+ wpa2-leap
+ wpa2-peap
++wpa2-ttls
+ wep-hex
+ wep-passphrase
+ wep-shared
+diff --git a/encryption/templates/wpa2-ttls b/encryption/templates/wpa2-ttls
+new file mode 100644
+index 0000000..4f66a1e
+--- /dev/null
++++ b/encryption/templates/wpa2-ttls
+@@ -0,0 +1,20 @@
++name = WPA2-TTLS (used notably by Eduroam)
++author = various contributors
++version = 1
++require identity *Identity anonymous_identity *Anonymous_identity password *Password ca_cert *Path_to_CA_Cert
++protected password *Password
++-----
++ctrl_interface=/var/run/wpa_supplicant
++network={
++        ssid="$_ESSID"
++        scan_ssid=$_SCAN
++        proto=WPA2
++        key_mgmt=WPA-EAP
++        group=CCMP TKIP
++        eap=TTLS
++        identity="$_IDENTITY"
++        password="$_PASSWORD"
++        anonymous_identity="$_ANONYMOUS_IDENTITY"
++        ca_cert="$_CA_CERT"
++        phase2="auth=PAP"
++}
diff --git a/gnu/packages/wicd.scm b/gnu/packages/wicd.scm
index ad3aa58cdb..350baf7373 100644
--- a/gnu/packages/wicd.scm
+++ b/gnu/packages/wicd.scm
@@ -2,6 +2,7 @@
 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2015 Pierre-Antoine Rault <par@rigelk.eu>
 ;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2016 Ludovic Courtès <ludo@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -48,7 +49,8 @@
        (patches (map search-patch
                      '("wicd-bitrate-none-fix.patch"
                        "wicd-get-selected-profile-fix.patch"
-                       "wicd-urwid-1.3.patch")))))
+                       "wicd-urwid-1.3.patch"
+                       "wicd-wpa2-ttls.patch")))))
     (build-system python-build-system)
     (native-inputs `(("gettext" ,gnu-gettext)))
     (inputs `(("dbus-glib" ,dbus-glib)