summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/statistics.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 401cb17e69..306df9cefd 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -4819,3 +4819,21 @@ particularly suited for high dimensional data.  Ensembles of classification,
 regression, survival and probability prediction trees are supported.  Data from
 genome-wide association studies can be analyzed efficiently.")
     (license license:gpl3)))
+
+(define-public r-tsne
+  (package
+    (name "r-tsne")
+    (version "0.1-3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "tsne" version))
+       (sha256
+        (base32
+         "0s8cv2pndkddq62rzlgzgfdjp1vjv5hz5i5957sllnb97vbzbzb6"))))
+    (build-system r-build-system)
+    (home-page "https://github.com/jdonaldson/rtsne/")
+    (synopsis "t-Distributed Stochastic Neighbor Embedding for R")
+    (description
+     "This package provides a pure R implementation of the t-SNE algorithm.")
+    (license license:gpl2+)))