summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu-system.am2
-rw-r--r--gnu/packages/autotools.scm63
-rw-r--r--gnu/packages/patches/libtool-2.4-skip-tests.patch24
-rw-r--r--gnu/packages/patches/libtool-skip-tests-for-mips.patch12
-rw-r--r--gnu/packages/patches/libtool-skip-tests.patch53
5 files changed, 42 insertions, 112 deletions
diff --git a/gnu-system.am b/gnu-system.am
index 5dd3a4937e..03b4134019 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -407,8 +407,6 @@ dist_patch_DATA =						\
   gnu/packages/patches/libmad-mips-newgcc.patch			\
   gnu/packages/patches/libtheora-config-guess.patch		\
   gnu/packages/patches/libtool-skip-tests.patch			\
-  gnu/packages/patches/libtool-skip-tests-for-mips.patch	\
-  gnu/packages/patches/libtool-2.4-skip-tests.patch		\
   gnu/packages/patches/libssh-CVE-2014-0017.patch		\
   gnu/packages/patches/lm-sensors-hwmon-attrs.patch		\
   gnu/packages/patches/luit-posix.patch				\
diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index eb33009d83..0ee1d149b9 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -238,31 +238,38 @@ Makefile, simplifying the entire process for the developer.")
 (define-public libtool
   (package
     (name "libtool")
-    (version "2.4.2")
+    (version "2.4.4")
     (source (origin
-             (method url-fetch)
-             (uri (string-append "mirror://gnu/libtool/libtool-"
-                                 version ".tar.gz"))
-             (sha256
-              (base32
-               "0649qfpzkswgcj9vqkkr9rn4nlcx80faxpyqscy2k1x9c94f93dk"))
-             (patches
-              (list (search-patch "libtool-skip-tests.patch")
-                    (search-patch "libtool-skip-tests-for-mips.patch")))))
+              (method url-fetch)
+              (uri (string-append "mirror://gnu/libtool/libtool-"
+                                  version ".tar.xz"))
+              (sha256
+               (base32
+                "0v3zq08qxv7k5067mpqrkjkjl3wphhg06i696mka90mzadc5nad8"))
+              (patches
+               (list (search-patch "libtool-skip-tests.patch")))))
     (build-system gnu-build-system)
     (native-inputs `(("m4" ,m4)
-                     ("perl" ,perl)))
+                     ("perl" ,perl)
+                     ("automake" ,automake)      ;some tests rely on 'aclocal'
+                     ("autoconf" ,(autoconf-wrapper)))) ;others on 'autom4te'
 
     ;; Separate binaries from the rest.  During bootstrap, only ltdl is
     ;; used; not depending on the binaries allows us to avoid retaining
     ;; a reference to the bootstrap bash.
-    (outputs '("bin"                         ; libtoolize, libtool, etc.
-               "out"))                       ; libltdl.so, ltdl.h, etc.
+    (outputs '("bin"                              ;libtoolize, libtool, etc.
+               "out"))                            ;libltdl.so, ltdl.h, etc.
 
     (arguments
      (if (%current-target-system)
-         '()                            ; no `check' phase when cross-building
-         '(#:phases (alist-cons-before
+         '()                             ;no `check' phase when cross-building
+         `(;; XXX: There are test failures on mips64el-linux starting from 2.4.4:
+           ;; <http://hydra.gnu.org/build/181662>.
+           #:tests? ,(not (string-prefix? "mips64"
+                                          (or (%current-target-system)
+                                              (%current-system))))
+
+           #:phases (alist-cons-before
                      'check 'pre-check
                      (lambda* (#:key inputs #:allow-other-keys)
                        ;; Run the test suite in parallel, if possible.
@@ -285,32 +292,6 @@ complexity of working with shared libraries across platforms.")
     (license gpl3+)
     (home-page "http://www.gnu.org/software/libtool/")))
 
-(define-public libtool-2.4.4
-  (package (inherit libtool)
-    (version "2.4.4")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "mirror://gnu/libtool/libtool-"
-                                  version ".tar.xz"))
-              (sha256
-               (base32
-                "0v3zq08qxv7k5067mpqrkjkjl3wphhg06i696mka90mzadc5nad8"))
-              (patches
-               (list (search-patch "libtool-2.4-skip-tests.patch")))))
-
-    (native-inputs `(("automake" ,automake)      ;some tests rely on 'aclocal'
-                     ("autoconf" ,(autoconf-wrapper)) ;others on 'autom4te'
-                     ,@(package-native-inputs libtool)))
-
-    (arguments
-     ;; XXX: There are test failures on mips64el-linux starting from 2.4.4:
-     ;; <http://hydra.gnu.org/build/181662>.
-     (if (string-prefix? "mips64el"
-                         (or (%current-target-system) (%current-system)))
-         `(#:tests? #f
-           ,@(package-arguments libtool))
-         (package-arguments libtool)))))
-
 (define-public libltdl
   ;; This is a libltdl package separate from the libtool package.  This is
   ;; useful because, unlike libtool, it has zero extra dependencies (making it
diff --git a/gnu/packages/patches/libtool-2.4-skip-tests.patch b/gnu/packages/patches/libtool-2.4-skip-tests.patch
deleted file mode 100644
index 95747dfef0..0000000000
--- a/gnu/packages/patches/libtool-2.4-skip-tests.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-Because our GCC 'lib' spec automatically adds '-rpath' for each '-L'
-and a couple more '-rpath, there are two test failures:
-one in demo.test, and one in destdir.at.  Disable these.
-
---- libtool-2.4.4/tests/testsuite	2014-11-29 17:43:11.000000000 +0100
-+++ libtool-2.4.4/tests/testsuite	2015-01-03 23:00:09.367775122 +0100
-@@ -9185,7 +9185,7 @@ read at_status <"$at_status_file"
- #AT_START_33
- at_fn_group_banner 33 'demo.at:548' \
-   "hardcoding library path" "                        " 3
--at_xfail=no
-+at_xfail=yes
-       test no = "$ACLOCAL" && at_xfail=yes
-       test no = "$AUTOHEADER" && at_xfail=yes
-       test no = "$AUTOMAKE" && at_xfail=yes
-@@ -27052,7 +27052,7 @@ read at_status <"$at_status_file"
- #AT_START_97
- at_fn_group_banner 97 'destdir.at:75' \
-   "DESTDIR with in-package deplibs" "                " 7
--at_xfail=no
-+at_xfail=yes
-       eval `$LIBTOOL --config | $GREP '^fast_install='`
-            case $fast_install in no) :;; *) false;; esac && at_xfail=yes
- (
diff --git a/gnu/packages/patches/libtool-skip-tests-for-mips.patch b/gnu/packages/patches/libtool-skip-tests-for-mips.patch
deleted file mode 100644
index 36587d23c2..0000000000
--- a/gnu/packages/patches/libtool-skip-tests-for-mips.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-TEMPORARY HACK: Disable a test that fails on MIPS.
-
---- libtool/Makefile.in.orig	2011-10-17 06:18:55.000000000 -0400
-+++ libtool/Makefile.in	2013-10-12 20:41:50.669067382 -0400
-@@ -890,7 +890,6 @@
- 	tests/demo-pic-make.test \
- 	tests/demo-pic-exec.test \
- 	tests/demo-nopic.test \
--	tests/demo-nopic-make.test \
- 	tests/demo-nopic-exec.test \
- 	tests/cdemo-shared.test \
- 	tests/cdemo-shared-make.test \
diff --git a/gnu/packages/patches/libtool-skip-tests.patch b/gnu/packages/patches/libtool-skip-tests.patch
index 6e12615d51..95747dfef0 100644
--- a/gnu/packages/patches/libtool-skip-tests.patch
+++ b/gnu/packages/patches/libtool-skip-tests.patch
@@ -1,37 +1,24 @@
-Because our GCC `lib' spec automatically adds `-rpath' for each `-L'
-and a couple more `-rpath, there are two test failures:
-demo-hardcode.test, and destdir.at.  Disable these.
+Because our GCC 'lib' spec automatically adds '-rpath' for each '-L'
+and a couple more '-rpath, there are two test failures:
+one in demo.test, and one in destdir.at.  Disable these.
 
---- libtool-2.4.2/Makefile.in	2011-10-17 12:18:55.000000000 +0200
-+++ libtool-2.4.2/Makefile.in	2012-09-13 23:50:37.000000000 +0200
-@@ -909,7 +908,7 @@ COMMON_TESTS = \
- # but they depend on the other tests being run beforehand.
- INTERACTIVE_TESTS = tests/demo-shared.test tests/demo-shared-make.test \
- 	tests/demo-shared-exec.test tests/demo-shared-inst.test \
--	tests/demo-hardcode.test tests/demo-relink.test \
-+	tests/demo-relink.test \
- 	tests/demo-noinst-link.test tests/demo-shared-unst.test \
- 	tests/depdemo-shared.test tests/depdemo-shared-make.test \
- 	tests/depdemo-shared-exec.test tests/depdemo-shared-inst.test \
-@@ -2580,8 +2579,7 @@ tests/cdemo-static-make.log:	tests/cdemo
- 
- tests/demo-shared-unst.log:	tests/demo-noinst-link.log
- tests/demo-noinst-link.log:	tests/demo-relink.log
--tests/demo-relink.log:		tests/demo-hardcode.log
--tests/demo-hardcode.log:	tests/demo-shared-inst.log
-+tests/demo-relink.log:		tests/demo-shared-inst.log
- tests/demo-shared-inst.log:	tests/demo-shared-exec.log
- tests/demo-shared-exec.log:	tests/demo-shared-make.log
- tests/demo-shared-make.log:	tests/demo-shared.log
-
---- libtool-2.4.2/tests/testsuite	2011-10-17 12:19:52.000000000 +0200
-+++ libtool-2.4.2/tests/testsuite	2012-09-14 00:28:45.000000000 +0200
-@@ -14443,6 +14443,6 @@ read at_status <"$at_status_file"
- #AT_START_69
- at_fn_group_banner 69 'destdir.at:75' \
-   "DESTDIR with in-package deplibs" "                " 4
+--- libtool-2.4.4/tests/testsuite	2014-11-29 17:43:11.000000000 +0100
++++ libtool-2.4.4/tests/testsuite	2015-01-03 23:00:09.367775122 +0100
+@@ -9185,7 +9185,7 @@ read at_status <"$at_status_file"
+ #AT_START_33
+ at_fn_group_banner 33 'demo.at:548' \
+   "hardcoding library path" "                        " 3
+-at_xfail=no
++at_xfail=yes
+       test no = "$ACLOCAL" && at_xfail=yes
+       test no = "$AUTOHEADER" && at_xfail=yes
+       test no = "$AUTOMAKE" && at_xfail=yes
+@@ -27052,7 +27052,7 @@ read at_status <"$at_status_file"
+ #AT_START_97
+ at_fn_group_banner 97 'destdir.at:75' \
+   "DESTDIR with in-package deplibs" "                " 7
 -at_xfail=no
 +at_xfail=yes
-       eval `$LIBTOOL --config | grep '^fast_install='`
+       eval `$LIBTOOL --config | $GREP '^fast_install='`
             case $fast_install in no) :;; *) false;; esac && at_xfail=yes
-
+ (