summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/pdf.scm8
-rw-r--r--gnu/packages/python.scm3
2 files changed, 3 insertions, 8 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 171f1990f7..e447ef1603 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -650,14 +650,10 @@ using a stylus.")
     (description "This is the ReportLab PDF Toolkit.  It allows rapid creation
 of rich PDF documents, and also creation of charts in a variety of bitmap and
 vector formats.")
-    (license license:bsd-3)
-    (properties `((python2-variant . ,(delay python2-reportlab))))))
+    (license license:bsd-3)))
 
 (define-public python2-reportlab
-  (package
-    (inherit (package-with-python2
-              (strip-python2-variant python-reportlab)))
-    (native-inputs `(("python2-pip" ,python2-pip)))))
+  (package-with-python2 python-reportlab))
 
 (define-public impressive
   (package
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 02e2900d2c..f103706533 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2044,8 +2044,7 @@ and sensible default behaviors into your setuptools run.")
      `(("python-six" ,python-six)
        ("python-pbr-0.11" ,python-pbr-0.11)))
     (inputs
-     `(("python-pip" ,python-pip)
-       ;; Tests
+     `(;; Tests
        ("python-testtools" ,python-testtools)))
     (arguments
      '(#:tests? #f)) ; no setup.py test command