summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index ceb6918e79..7a1cae6a8c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -340,10 +340,14 @@ CLEANFILES =					\
   $(GOBJECTS)					\
   $(SCM_TESTS:%.scm=%.log)
 
+AM_V_GUILEC = $(AM_V_GUILEC_$(V))
+AM_V_GUILEC_ = $(AM_V_GUILEC_$(AM_DEFAULT_VERBOSITY))
+AM_V_GUILEC_0 = @echo "  GUILEC" $@;
+
 # XXX: Use the C locale for when Guile lacks
 # <http://git.sv.gnu.org/cgit/guile.git/commit/?h=stable-2.0&id=e2c6bf3866d1186c60bacfbd4fe5037087ee5e3f>.
 .scm.go:
-	$(MKDIR_P) `dirname "$@"`
+	$(AM_V_GUILEC)$(MKDIR_P) `dirname "$@"` ;			\
 	LC_ALL=C							\
 	$(top_builddir)/pre-inst-env					\
 	$(GUILD) compile -L "$(top_builddir)" -L "$(top_srcdir)"	\