summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/pretty-print.scm70
1 files changed, 34 insertions, 36 deletions
diff --git a/gnu/packages/pretty-print.scm b/gnu/packages/pretty-print.scm
index 13108fe7db..9745a9ba10 100644
--- a/gnu/packages/pretty-print.scm
+++ b/gnu/packages/pretty-print.scm
@@ -32,7 +32,6 @@
   #:use-module (guix download)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system gnu)
-  #:use-module (guix gexp)
   #:use-module (guix utils)
   #:use-module (gnu packages)
   #:use-module (gnu packages bison)
@@ -277,41 +276,40 @@ to @code{IOStreams}.")
      (list boost))
     (native-inputs
      (list bison flex))
-    (arguments   
-     (list #:configure-flags
-           #~(list (string-append "--with-boost=" (assoc-ref %build-inputs "boost")))
-           #:parallel-tests? #f ;There appear to be race conditions
-           #:phases
-           #~(modify-phases %standard-phases
-               (add-before 'build 'rename-lesspipe-to-lesspipe.sh.in
-                 (lambda _
-                   (substitute* "src/src-hilite-lesspipe.sh.in"
-                     (("lesspipe") "lesspipe.sh"))))
-           #$@(if (%current-target-system)
-                  ;; 'doc/Makefile.am' tries to run stuff even when
-                  ;; cross-compiling.  Explicitly skip it.
-                  ;; XXX: Inline this on next rebuild cycle.
-                  #~((add-before 'build 'skip-doc-directory
-                       (lambda _
-                         (substitute* "Makefile"
-                           (("^SUBDIRS = (.*) doc(.*)$" _ before after)
-                            (string-append "SUBDIRS = " before
-                                           " " after "\n"))))))
-                  '())
-               (add-before 'check 'patch-test-files
-                  (lambda _
-                    ;; Unpatch shebangs in test input so that source-highlight
-                    ;; is still able to infer input language
-                    (substitute* '("tests/test.sh"
-                                   "tests/test2.sh"
-                                   "tests/test.tcl")
-                      (((string-append "#! *" (which "sh"))) "#!/bin/sh"))
-                    ;; Initial patching unrecoverably removes whitespace, so
-                    ;; remove it also in the comparison output.
-                    (substitute* '("tests/test.sh.html"
-                                   "tests/test2.sh.html"
-                                   "tests/test.tcl.html")
-                      (("#! */bin/sh") "#!/bin/sh")))))))
+    (arguments
+     `(#:configure-flags
+       (list (string-append "--with-boost="
+                            (assoc-ref %build-inputs "boost")))
+       #:parallel-tests? #f             ;There appear to be race conditions
+       #:phases
+       (modify-phases %standard-phases
+         ,@(if (%current-target-system)
+               ;; 'doc/Makefile.am' tries to run stuff even when
+               ;; cross-compiling.  Explicitly skip it.
+               ;; XXX: Inline this on next rebuild cycle.
+               `((add-before 'build 'skip-doc-directory
+                   (lambda _
+                     (substitute* "Makefile"
+                       (("^SUBDIRS = (.*) doc(.*)$" _ before after)
+                        (string-append "SUBDIRS = " before
+                                       " " after "\n")))
+                     #t)))
+               '())
+         (add-before 'check 'patch-test-files
+           (lambda _
+             ;; Unpatch shebangs in test input so that source-highlight
+             ;; is still able to infer input language
+             (substitute* '("tests/test.sh"
+                            "tests/test2.sh"
+                            "tests/test.tcl")
+               (((string-append "#! *" (which "sh"))) "#!/bin/sh"))
+             ;; Initial patching unrecoverably removes whitespace, so
+             ;; remove it also in the comparison output.
+             (substitute* '("tests/test.sh.html"
+                            "tests/test2.sh.html"
+                            "tests/test.tcl.html")
+               (("#! */bin/sh") "#!/bin/sh"))
+             #t)))))
     (home-page "https://www.gnu.org/software/src-highlite/")
     (synopsis "Produce a document with syntax highlighting from a source file")
     (description