summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/bdw-gc.scm6
-rw-r--r--gnu/packages/guile.scm12
2 files changed, 5 insertions, 13 deletions
diff --git a/gnu/packages/bdw-gc.scm b/gnu/packages/bdw-gc.scm
index 8142b4c4ef..fb3c43da89 100644
--- a/gnu/packages/bdw-gc.scm
+++ b/gnu/packages/bdw-gc.scm
@@ -23,7 +23,7 @@
   #:use-module (guix build-system gnu)
   #:use-module (gnu packages pkg-config))
 
-(define-public libgc
+(define-public libgc-7.2
   (package
    (name "libgc")
    (version "7.2e")
@@ -86,8 +86,8 @@ lock-free code, experiment with thread programming paradigms, etc.")
     ;; Some source files are X11-style, others are GPLv2+.
     (license gpl2+)))
 
-(define-public libgc-7.4
-  (package (inherit libgc)
+(define-public libgc
+  (package (inherit libgc-7.2)
     (version "7.4.0")
     (source (origin
               (method url-fetch)
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 29ec1096dc..838833fcf4 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -136,7 +136,7 @@ without requiring the source code to be rewritten.")
 
       ;; The headers and/or `guile-2.0.pc' refer to these packages, so they
       ;; must be propagated.
-      ("bdw-gc" ,libgc-7.4)
+      ("bdw-gc" ,libgc)
       ("gmp" ,gmp)))
 
    (self-native-input? #t)
@@ -175,15 +175,7 @@ without requiring the source code to be rewritten.")
 (define-public guile-2.0/fixed
   ;; A package of Guile 2.0 that's rarely changed.  It is the one used
   ;; in the `base' module, and thus changing it entails a full rebuild.
-  (package (inherit guile-2.0)
-    (location (source-properties->location (current-source-location)))
-
-    ;; Keep using the stable libgc.
-    (propagated-inputs (map (match-lambda
-                             (("bdw-gc" _)
-                              `("bdw-gc" ,libgc))
-                             (x x))
-                            (package-propagated-inputs guile-2.0)))))
+  guile-2.0)
 
 
 ;;;