summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/video.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 214aba26aa..3393a9db65 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1713,6 +1713,10 @@ operate properly.")
          ;; The static libraries are 23 MiB
          "--disable-static"
 
+         #$@(if (target-riscv64?)
+              '("--extra-cflags=-fPIC")
+              '())
+
          ;; Runtime cpu detection is not implemented on
          ;; MIPS, so we disable some features.
          "--disable-mips32r2"