summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/julia.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/julia.scm b/gnu/packages/julia.scm
index 5cb4e53140..d8a6d7ac2f 100644
--- a/gnu/packages/julia.scm
+++ b/gnu/packages/julia.scm
@@ -201,9 +201,10 @@
        (modify-phases %standard-phases
          (delete 'configure)
          (add-before 'check 'set-ld-library-path
-           (lambda* (#:key native-inputs #:allow-other-keys)
+           (lambda* (#:key native-inputs inputs #:allow-other-keys)
              (setenv "LD_LIBRARY_PATH"
-                     (string-append (assoc-ref native-inputs "zlib") "/lib"))))
+                     (string-append (assoc-ref (or native-inputs inputs) "zlib")
+                                    "/lib"))))
          (replace 'install
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out")))