summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python.scm27
1 files changed, 2 insertions, 25 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index c0686b0128..25ad86f204 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -371,6 +371,7 @@ data types.")
               (uri (string-append "https://www.python.org/ftp/python/"
                                   version "/Python-" version ".tar.xz"))
               (patches (search-patches
+                        "python-3-arm-alignment.patch"
                         "python-3-fix-tests.patch"
                         "python-3.8-fix-tests.patch"
                         "python-3-deterministic-build-info.patch"
@@ -473,33 +474,9 @@ data types.")
                                          ,file)))
                               (find-files out "\\.py$")))
                   (list '() '("-O") '("-OO")))
-                 #t)))
-           ;; XXX: Apply patch on ARM platforms only to avoid a full rebuild.
-           ;; Remove this phase in the next rebuild cycle.
-           ,@(let ((system (or (%current-target-system)
-                               (%current-system))))
-               (if (any (cute string-prefix? <> system)
-                        '("arm" "aarch64"))
-                   '((add-after 'unpack 'apply-alignment-patch
-                       (lambda* (#:key native-inputs inputs #:allow-other-keys)
-                         (invoke "patch" "-p1" "--force" "--input"
-                                 (assoc-ref (or native-inputs inputs)
-                                            "arm-alignment.patch")))))
-                   '()))))))
+                 #t)))))))
     (native-inputs
      `(("tzdata" ,tzdata-for-tests)
-
-       ;; Disable unaligned accesses in the sha3 module on ARM as
-       ;; it causes a test failure when building 32-bit Python on a
-       ;; 64-bit kernel.  See <https://bugs.python.org/issue36515>.
-       ;; TODO: make this a regular patch in the next rebuild cycle.
-       ,@(let ((system (or (%current-target-system)
-                           (%current-system))))
-           (if (any (cute string-prefix? <> system)
-                    '("arm" "aarch64"))
-               `(("arm-alignment.patch" ,(search-patch "python-3-arm-alignment.patch")))
-               '()))
-
        ,@(if (%current-target-system)
              `(("python3" ,this-package))
              '())