summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 43b0e26f8b..f020e1a62a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6167,14 +6167,14 @@ printing of sub-tables by specifying a row range.")
              #t))
          (replace 'build
            (lambda* (#:key inputs #:allow-other-keys)
-             (zero? (system* "python" "setup.py" "build"
-                             (string-append "--hdf5="
-                                            (assoc-ref inputs "hdf5"))))))
+             (invoke "python" "setup.py" "build"
+                     (string-append "--hdf5="
+                                    (assoc-ref inputs "hdf5")))))
          (replace 'check
            (lambda* (#:key inputs #:allow-other-keys)
-             (zero? (system* "python" "setup.py" "check"
-                             (string-append "--hdf5="
-                                            (assoc-ref inputs "hdf5")))))))))
+             (invoke "python" "setup.py" "check"
+                     (string-append "--hdf5="
+                                    (assoc-ref inputs "hdf5"))))))))
     (propagated-inputs
      `(("python-numexpr" ,python-numexpr)
        ("python-numpy" ,python-numpy)))