summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-xyz.scm46
1 files changed, 23 insertions, 23 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e99587cf67..771b00e047 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -30228,32 +30228,29 @@ development, testing, production]};
 @end itemize")
     (license license:expat)))
 
-(define-public pudb
+(define-public python-pudb
   (package
-    (name "pudb")
-    (version "2021.2")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (pypi-uri "pudb" version))
-       (sha256
-        (base32 "0p16pvzfa3w02ybg3n0iy5rs23z4rz4a42lb8wh3mcq62y9ik2w7"))))
+    (name "python-pudb")
+    (version "2022.1.1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "pudb" version))
+              (sha256
+               (base32
+                "0gq82hwnibby9qdyv7ri11phvg94nby4jb0w9h3jk79w89kdsfyv"))))
     (build-system python-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-before 'check 'fix-read-only-home
-           (lambda _
-             (setenv "HOME" "/tmp")))
-         (replace 'check
-           (lambda* (#:key inputs outputs tests? #:allow-other-keys)
-             (when tests?
-               (add-installed-pythonpath inputs outputs)
-               (invoke "pytest")))))))
-    (native-inputs
-     (list python-numpy python-pytest python-pytest-mock))
-    (propagated-inputs
-     (list python-jedi python-pygments python-urwid python-urwid-readline))
+     `(#:phases (modify-phases %standard-phases
+                  (add-before 'check 'fix-read-only-home
+                    (lambda _
+                      (setenv "HOME" "/tmp")))
+                  (replace 'check
+                    (lambda* (#:key tests? #:allow-other-keys)
+                      (when tests?
+                        (invoke "pytest" "-vv")))))))
+    (native-inputs (list python-pytest python-pytest-mock))
+    (propagated-inputs (list python-jedi python-pygments python-urwid
+                             python-urwid-readline))
     (home-page "https://documen.tician.de/pudb/")
     (synopsis "Console-based Python debugger")
     (description
@@ -30262,6 +30259,9 @@ all the niceties of modern GUI-based debuggers in a more lightweight and
 keyboard-friendly package.")
     (license license:expat)))
 
+(define-public pudb
+  (deprecated-package "pudb" python-pudb))
+
 (define-public python-iwlib
   (package
     (name "python-iwlib")