summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ocaml.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 4313bde8a8..93020f1c06 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -834,7 +834,10 @@ files in these formats.")
     (native-inputs
      `(("ounit" ,ocaml-ounit)))
     (arguments
-     `(#:tests? #f)) ; tests are done during build
+     `(#:phases
+       (modify-phases %standard-phases
+         ;; Tests are done during build.
+         (delete 'check))))
     (home-page "https://forge.ocamlcore.org/projects/ocamlmod")
     (synopsis "Generate modules from OCaml source files")
     (description "Generate modules from OCaml source files.")