summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/bioconductor.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 4fc7fcbf32..7127e963bb 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1789,3 +1789,27 @@ Distance Summary), which selects differentially expressed genes by integrating
 and summarizing a set of statistics using a weighted distance approach.")
     ;; Any version of the LGPL.
     (license license:lgpl3+)))
+
+;; This is a CRAN package, but since it depends on a Bioconductor package we
+;; put it here.
+(define-public r-nbpseq
+  (package
+    (name "r-nbpseq")
+    (version "0.3.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "NBPSeq" version))
+       (sha256
+        (base32
+         "0l4ylxhs2k9ww21jjqs67fygk92avdchhx2y1ixzl7yr2yh1y9by"))))
+    (properties `((upstream-name . "NBPSeq")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-qvalue" ,r-qvalue)))
+    (home-page "https://cran.r-project.org/web/packages/NBPSeq")
+    (synopsis "Negative binomial models for RNA-Seq data")
+    (description
+     "This package provides negative binomial models for two-group comparisons
+and regression inferences from RNA-sequencing data.")
+    (license license:gpl2)))